Newbie difficulties



  • I am brand new to Linux and QT. Running QT Creator under Ubuntu.

    Start QT Creator and it opens in a maximized state. I don't want it maximized. I look here: http://doc.qt.io/qtcreator/creator-quick-tour.html and it shows an image of QT Creator running. In the upper right corner of the display are the usual symbols to minimize the display (a dash charcter), to maximize/minimize the display (two squares one occluding the other) and to close the application (the X character).
    None of those buttons are displayed on my screen. Neither are all the tool menu buttons, File, Edit, Build, etc.
    What steps will get these controls displayed? Is a re-install warranted?

    QT displays buttons labeled "New Project" and "Open Project." I don't want either one. I just want to edit a dot json file so I can see it formatted as I saw it when someone else was use QT on their system. What steps will allow me to open a file?



  • @BKBK hi, and welcome to the forum.

    Which version of Creator are you running? there has been some problems with the Ubuntu Global Menu. That has been fixed in Creator 4.3 IMHO.

    There was a post here in the forum talking about this problem, I just dont find it.

    Edit: But I found the bug report: https://bugreports.qt.io/browse/QTCREATORBUG-17519


  • Moderators

    @BKBK Standard Ubuntu uses its own desktop environment called Unity (this will change with next release, then Ubuntu will use Gnome). In Unity you do not see those buttons to close, maximize and minimize buttons if the window is maximized. You need to move the mouse button to the top of the screen. Same applies to the menu. This is completely unrelated to QtCreator, it is how standard Ubuntu behaves.

    ""New Project" and "Open Project." I don't want either one" - what is the problem to have those? QtCreator is an IDE and as such it manages software projects, that's why it has these entries in the menu.

    "I just want to edit a dot json file so I can see it formatted" - for this task you do not need an IDE like QtCreator, you can do it in an editor like GEdit.

    "What steps will allow me to open a file?" - same as with any editor: either press Ctrl-O or move mouse button to the top of the screen until you see the menu and go to "File/Open File With...".



  • @BKBK said in Newbie difficulties:

    None of those buttons are displayed on my screen. Neither are all the tool menu buttons, File, Edit, Build, etc.

    The first thing I strongly suggest you do in Unity desktop is:

    1. Click on the "cog wheel" icon at the very top-right of the horizontal bar at the top of the desktop, and pick System Settings....
    2. Click on the Appearance icon in Personal section.
    3. Click on the Behaviour tab.
    4. In Show the menus for a window, set the radio button to In the window's title bar.

    Now your menus appear in each window, instead of system-wide, like they do in most other desktops (e.g. Windows)!



  • Ubuntu version is 16.04 LTS
    The QT manual shows version 3.5.1. I am unable to find anything that specifically states the version of QT itself. However, on the upper right is the text “Unfiltered” with up down arrows to its right. When clicked a long list of QT menu items is shown and all begin with 5.8.
    Is it worth nothing that once I open the manual I cannot find a way to close it without restarting QT?
    I followed JNBarchan’s suggestion first to display the menus. It made no difference in the QT Creator window. So I rebooted Ubunto, the menus were not displayed, checked the settings, they were as I left them before the reboot.
    To recap, in the QT Creator screen, the options to set window size to min or max, and to exit the app are not visible. Neither are all the normal menu items such as File, Edit, etc.
    When I wrote that I don’t want New Project and Open Project, that was imprecise and I was a bit frustrated. I intended that they were not needed at the moment. The immediate need was and is the ability to select a particular file and open it.
    Jsulm noted I should use ctl-O. I completely forgot about that and it does work. How do I get QT to display the file like source code showing the indents due to grouping such as { and }?



  • @BKBK

    I followed JNBarchan’s suggestion first to display the menus. It made no difference in the QT Creator window. So I rebooted Ubunto, the menus were not displayed, checked the settings, they were as I left them before the reboot.

    Not sure what you are referring to by "checked the settings, they were as I left them before the reboot."? The change I told you to make --- which BTW I am recommending you adopt for all apps run in your desktop, nothing to do with Qt, so I think you should have it anyway --- is set via your System Settings..., and should certainly persist across reboot. They also affect all your programs which have a window, so you should see the difference e.g. in Terminal or a LibreOffice app? Are you saying your System Settings are not being preserved, because that would be worrying...?

    For your Qt Creator problem, it might be time to show a screenshot of your whole desktop situation so that we can see what you mean?



  • Hello JNBarchan,
    I made the Ubuntu system changes as you noted and those changes did persist across a reboot. But they made no difference in the QT screen. I still have no method of (de)maximizing the QT window and no menus such as File, Edit, etc. The only way I can quit QT is to go to the application icons on the left side of the screen, right click, and select Quit.
    I am on a government installation and my Linux computer is not authorized to connect to the base network. That means I must capture the screen, burn to a CD, and bring it over here. I may have to do that quickly. Inserting a USB device on a network computer is a firing offense. The government has had a lot of problems with USB devices.
    I have been working in Windows for a long time. I joined the project as the only software engineer and suddenly we discovered the need for Linux. I am way out of my comfort zone and that is a bit of a problem. I am happy to do that, but it makes meeting milestones rather difficult.

    BTW: When signing up I tried to enter BK for my user name but this site demanded four characters, so I put in BK twice. Now in settings and profile I do not see a method to change that. It that permanent?


  • Moderators

    @BKBK Did you try to move mouse cursor to the top of the windows as I suggested? You then should see the buttons to maximise/minimise the window. I have Ubuntu here with Unity and no problems.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.