How to add MapboxGL support?



  • I have been trying to add MapboxGL support to my deploy system without any luck.

    Situation:

    • Building/compiling on Ubuntu 16.04 LTS (x64)
    • Deploy to Raspberry Pi 3 (arm) | Target
    • Target uses EGLFS
    • Target Qt version: 5.10.0
    • Target build using http://wiki.qt.io/RaspberryPi2EGLFS
    • Target build came without any modules pre-installed
    • Unable to get MapboxGL working on target system
    • Open-Source
    // Getting the modules
    git clone https://github.com/qt/qtlocation.git -b 5.10
    git clone https://github.com/qt/qtlocation-mapboxgl.git -b 5.10
    
    // Git clone location
    ls /opt/raspi/modules/    
    qtlocation           
    qtlocation-mapboxgl 
    ...
    
    // How I added QtLocation
    cd /opt/raspi/modules/qtlocation
    /opt/raspi/qt5/bin/qmake -r
    make -j4
    make install
    rsync -avz /opt/raspi/qt5pi pi@QtDisplay.local:/usr/local
    
    ...
    Configure summary:
    
    Qt Positioning:
      Gypsy GPS Daemon ....................... no
      WinRT Geolocation API .................. no
    Qt Location:
      Geoservice plugins:
        OpenStreetMap ........................ yes
        HERE ................................. yes
        Esri ................................. yes
        Mapbox ............................... yes
        MapboxGL ............................. no
        Itemsoverlay ......................... yes
    
    

    qmake doesn't work in the qtlocation-mapboxgl folder.
    Using make && make qt-lib does succesfully compile libqmapboxgl.so into /opt/raspi/modules/qtlocation-mapboxgl/build/qt-linux-x86_64/Debug using my Ubuntu 16.04 LTS.

    But I am still unable to get the MapboxGL to turn into yes. Building example projects gives no errors, it just doesn't show up on the target device. Running it on my Ubuntu system works perfectly (used online-installer by qt).



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.