Upgrade OpenSSL version



  • Hi,

    I need to upgrade the OpenSSL version in the QT.
    Currently our QT is linked by a dll (We work with qtwebkit).
    Can I just replace the dlls, or I need to recompile the QT and QT webkit?
    Thanks


  • Lifetime Qt Champion

    Hi,

    Depends on the version of OpenSSL you want to use. If it's >= 1.1, then you have to use Qt 5.10 at least otherwise you should be fine just updating the .dlls.

    Don't forget to ensure you are using the a version built with the same compiler as your Qt version.



  • I want to upgrade to version 1.0.2m.

    1. What about the Linux and Osx platforms? is it the same - just to replace the libs\bins?
    2. In case that I don't use same compiler as in the QT version, to which problems should I expect?

  • Lifetime Qt Champion

    1. No, recent versions of Qt don't use OpenSSL at all on macOS, they use the native SecureTransport framework. As for Linux, it's your distributions that handles OpenSSL updates unless you provide an "all in one" package for your application.

    2. Failure to load and use the library.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.