Creator 4.4.1 on Mac 10.13 can't find Kits or Qt Versions



  • I'm new to Qt and trying to get Creator open source version 4.4.1 running on a Mac with OSX 10.13.1 and Xcode 9.1. Qt Creator does start OK. The only thing listed under Welcome, Examples is a minibrowser. When I try to configure it, it says "No valid kits found" and directs me to Build & Run Options where there's nothing autodetected under Kits or Qt Versions. I don't understand how Qt works or where all the pieces should be well enough to tell it where to look manually. I'd appreciate help getting the Example working. Thanks.


  • Qt Champions 2016

    Hi
    You did download something like
    https://download.qt.io/archive/qt/5.9/5.9.2/qt-opensource-mac-x64-5.9.2.dmg

    Creator is just the editor. you need a Qt version to go with it.

    How did you install Qt and Creator ?



  • No, I started from "Download Qt 5.9" on https://www1.qt.io/developers/ which I thought meant it would download everything. I'm downloading Qt from your link now. Thanks for responding so quickly.


  • Qt Champions 2016

    @SVanDee
    Hmm that should have also given you the full install.
    Did you deselect stuff in the online installer ?

    If still no kits detected, the Xcode might be unexpected version.
    Im sadly not using MacOS so im not sure what version will just be detected.

    https://www.ics.com/blog/getting-started-qt-and-qt-creator-macos

    Can also be related to the SDK it seems
    https://forums.developer.apple.com/thread/88135



  • I downloaded and installed qt-opensource-mac-x64-5.9.2.dmg in its default ~/Qt5.9.2 directory. It included a copy of Creator so I started it. Welcome, Examples is entirely blank. In Finder, I can see ~/Qt5.9.2/Examples/ which contains Qt-5.9.2/example.pro and a /Speech subfolder . In Creator, I opened example.pro. The only entry in the Build drop-down list that wasn't grayed out was Build & Run Kit Selector so I selected it. It said the project wasn't configured yet so I clicked Projects Mode from which I eventually ended up in Preferences, Build & Run page which says it can't autodetect any Kits or Qt Versions.

    I started MaintenanceTool.app, selected "Add or remove components" and clicked Continue. The page didn't change. It displayed "At least one valid and enabled repository required for this action to succeed." in red. In Settings, Repositories, "Default Repositories" was selected so I clicked OK. The red message is still there and Continue is grayed out. I don't know where to go from here.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you use the offline installer ?



  • I ran qt-opensource-mac-x64-5.9.2.dmg again and expanded the Qt components which I did not do before. I saw none of the components were selected by default except Speech. I selected macOS and IOS and some other components. Now I'm much further along. Kits and Versions in Creator, Build & Run Preferences are both populated and there are lots of Examples. When I select an example the Build & Kit Selector says the "Desktop Qt 5.9.2 clang 64 bit" kit is selected which sounds right. However, when I Run an example, it aborts immediately with "[main.o] Error 2] in the Issues tab. In the Compile Output window, I see that:

    • /Users/.../5.9.2/clang_64/bin/qmake exited normally
    • /usr/bin/make qmake_all said there was nothing to do and exited normally
    • /usr/bin/make started with a long list of parameters ending in
      -F/Users/stephenvandellen/Qt5.9.2(2)/5.9.2/clang_64/lib -o main.o ../chartthemes/main.cpp
      The next line, in red, says:
      /bin/sh: -c: line 0: syntax error near unexpected token `('
      (several more lines)
      12:01:03: The process "/usr/bin/make" exited with code 2.
      Error while building/deploying project chartthemes (kit: Desktop Qt 5.9.2 clang 64bit)
      When executing step "Make"

    So there does seem to be some incompatibility with the Xcode 9.1 but it doesn't sound quite like https://forums.developer.apple.com/thread/88135 since my system isn't having any problem finding files. I've never used Xcode so it's going take some research to figure out what might be wrong. Thanks for the help getting this far. I'll upvote your answer but leave the thread open hoping to add the rest of the solution for anyone else who needs it.



  • @SGaist I originally installed it:

    That's when I wrote the original post. Following mrjj's advice, I downloaded https://download.qt.io/archive/qt/5.9/5.9.2/qt-opensource-mac-x64-5.9.2.dmg which, after I figured out how to tell it to load the macOS components, gave me an installation with Kits and Qt Versions and lots of examples but which can't Build the examples as described above.



  • I intend to use Qt mainly from Python via PyQt. PyQt converts the .ui files Creator produces to Python modules so I guess I don't absolutely need to figure the Xcode interface out right now. I'd still like to be able to build and run Qt's examples but I'll mark this thread solved and wait for Qt to be updated to work with the more recent version of Xcode.



  • I re-installed Qt from https://download.qt.io/archive/qt/5.9/5.9.2/qt-opensource-mac-x64-5.9.2.dmg. The same examples that crashed earlier are working now. I don't know what I did differently. Anyhow, there doesn't appear to be any Qt/Xcode interface problem after all.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.