Qt Creator 4.4.1 on Win10 starts in background, no GUI

  • I've installed Qt 5.9.2 and Qt Creator 4.4.1 but when I launch Qt Creator the application does not show up. The process starts in background and is visible in task manager.

    I'm on a Windows 10 OS and I tried both the online and offline installers. I also tried to uninstall everything and install only Qt Creator. I tried the latest beta version of Qt Creator, the problem persists.

    I found a similar problem related to Qt designer. Unfortunately the proposed solution (removing/renaming qtwebengine dlls) does not apply to this case (the aforementioned dll is not part of Qt Creator).

    Any help with this would be greatly appreciated.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you try to start Qt Creator from the command line ? Might give some additional output about what is going on ?

  • Thanks for your reply. Yes, I tried that but nothing gets printed to the shell. In a way it makes sense, because the application starts (I can see it in the list of background processes), but the graphical user interface is not shown.

  • Hi, try launching Qt Creator again on the command line, but with some arguments:

    C:\Qt\Tools\QtCreator\bin>qtcreator -noload all -load Core

  • I uninstalled Qt creator once again and ran a registry cleaner. Then downloaded and installed Qt creator for the n-th time and this time it did start up correctly. I'm still baffled at what could have been possibly been wrong, but cleaning the registry did the trick. Hopefully this will help someone that stumbles upon the same issue.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.