Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Sorry but im done with QT



  • I dont know why, but i had so many Problems the last Time with QT. I really like QT, but i think im done with it for now. On Windows i cant add new QT Versions with the Maintaincetool und i cant Update anything, because i get Errors that Packages cant be download. And that since several Month. Now i have a Problem here that i cant solve https://forum.qt.io/topic/82572/qtableview-add-rows-renders-wrong and i tried to install some other Packages, but on Windows they are not listed in the Tool. So, as i had done several Times, i deinstall all and install all new. But now the Website is not working and i cant download the Installer.

    Somebody had similar Problems? I really mad at the Moment and take a look now at C# and WPF.


  • Lifetime Qt Champion

    @Fuel said in Sorry but im done with QT:

    But now the Website is not working and i cant download the Installer

    Works for me: https://www1.qt.io/download-open-source/?hsCtaTracking=f977210e-de67-475f-a32b-65cec207fd03|d62710cd-e1db-46aa-8d4d-2f1c1ffdacea#section-2
    Are you sure your computer or internet connection isn't the source of these problems?

    I never had such problems.



  • Now the download of the Installer works again.

    I dont think that it is my Internet Connection, because i dont have any Problems with anything. I had to reinstall everything the last time more then 1 or 2 times and everytime i had some Problems with downloading. The biggest Problem is updating, that only works if i try it about 20 times.



  • Do you necessarily have to download on the same day an update.

    If the maintenance tool servers or your (read mine) own internet has a day off ... I just put it off to try for the next day.

    Obviously I'd be slightly miffed if I had to do a full dev PC build on that day and couldn't ... luckily that happens very rarely and if it's just an update of things... I continue on with the current environment.

    The Qt technology itself is too useful for me to give it up because of shitty internet. I get more outages from people cutting major fiber links to the region than I experience a Qt server problem personally...

    Bastardizing the regular expression joke:
    you had a problem today so you went over to c# / WPF ... now you have 2 problems =) - but good luck - I personally am getting as far away from Microsoft as I can lately... I only develop on Windows because that's what we are currently targeting.

    If that decision were up to me I'd release an embedded boot to Qt/Linux device. I have a linux dev env setup and maintained for that day too... I still might get that... working on it.



  • I started today to try to install Qt again, but i always get a Timeout by downloading Metadata. I tried it at the Morning and Noon, but i cant install Qt at the Moment. Progress stops always between 50-60%.

    I love Qt too, but i hate this Problems. At the moment its frustrating.


  • Moderators

    @Fuel
    FYI: there are also offline installers available.



  • I know i tried that some Month ago. But the Offline Installer doesnt contains the Installer Framework or some other Tools i need. And after Installation there are no Servers setup in the Maintaince Tool, so that you cant install other Tools or do an Update. I dont know but there was a couple of Things i missed in the Offline Installer.
    And the Maintaince Tool cant add new Packages, because they are not listed. Like switching to 5.9.1 from 5.9. You have to do a complete reinstall.

    As i said i had to fight with this Problems many Months in a Row.



  • Hi, just guessing but maybe it's a firewall problem? You could try connecting to the internet through a VPN and then install Qt...



  • I dont think its a Firewall, because the Timeout occurs at 50-60% at different Packages. I need to try it many Times and sometimes im lucky and it works. Its only the Process where he try to recieve Metadata. After this, Installation works always fine.



  • Hmm, you also get the same Timeouts if you connect through Wi-Fi instead of a wired connection (or the other way around)?



  • Cant test it, but i dont have Problems with my wired Connection. I play Games, surf on Websites, watch Twitch Streams, Youtube Videos and so on. Qt Tool is the only Problem. Half Year ago i was thinking its me, but at the Moment i think its something else. I think the Tool uses the http Protocol.



  • Just checked the MaintenanceTool, I see that when it does "Retrieving meta information from remote repository" it connects to a server in Digia's network in Helsinki, Finland.

    Normally when the MaintenanceTool downloads stuff it tries to go first to a server in the same country you're in, but that "Retrieving meta information.." part seems hardwired to Digia in Finland.

    The URL to the Digia server is is http://download.qt.io/ see if you can download from it...



  • Now i tried to download the Package manually a few Times and it works great. I started the Tool

    0_1506158147168_Unbenannt.png

    and go to this Page and downloaded the Package. Works great, but the Tool wont download it.



  • Hmm, just guessing, but could it be your anti-virus program that somehow blocks the download?



  • I deactivated my Antivirus but still get the Timeout



  • Ok another guess: maybe the Tool cannot save the files, it uses the directory in the TMP env. variable to create about 70 subdirectories called remoterepo-1fjNoZ, remoterepo-Zt5JDQ etc.

    If you open a CMD window and type echo %TMP% you can check that the directory is a valid name on your harddisk.

    P.S. Also, you can try to run cleanmgr to clean the TMP directory.



  • I deinstalled my Antivirus, cleaned my TMP Directory and still get the Timeout. But after some tries now im able to install it again.


Log in to reply