Incompatible g++ and Qt versions?



  • I just installed Linux 32bit version of Qt Creator from the download page. I selected g++ as a compiler, so I installed g++ 6.3.0 (20170516), but now I have a warning sign left to the "Auto-detected" Kit version "Desktop Qt 5.5.1 GCC 32bit" and trying to compile even a simple project fails: in "Compile Output" window there is, for example:

    23:32:04: Running steps for project 123...
    23:32:04: Configuration unchanged, skipping qmake step.
    23:32:04: Could not start process "make" 
    Error while building/deploying project 123 (kit: Desktop Qt 5.5.1 GCC 32bit)
    When executing step "Make"
    23:32:04: Elapsed time: 00:00.
    

    How can I solve this problem?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you also install make ?

    What Linux distribution are you running ?



  • Thanks, installing "make" helped.


  • Lifetime Qt Champion

    Depending on your Linux distribution you have "pre-prepared" packages to setup a basic development environment like build-essential on Debian.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.