Gstreamer



  • I am trying to execute a Qt 5.8 app on Ubuntu 16.04. I have loaded gstreamer0.10 via

     sudo apt-get update
     sudo apt-get install gstreamer0.10-x
     sudo apt-get –f install
    

    Following various suggestions on the web, I have also loaded

     sudo add-apt-repository ppa:mc3man/gstffmpeg-keep
     sudo add-apt-repository ppa:mc3man/trusty
    

    However, when my app attempts to play a video, I receive the following error:

     Warning: No decoder available for type 'audio/x-m4a'
     Error: Your GStreamer installation is missing a plug-in.
    

    What is the proper method of installing gstreamer so that Qt can play videos?

    Thank you in advance.

    Hoyt


  • Lifetime Qt Champion

    Hi,

    You also need to install the gstreamer plugin packages.



  • SGaist,

    I just tried to install the gstreamer-ugly plugin via

     sudo apt install gstreamer0.10-plugins-ugly
    

    However, it seems that that package is no longer available. Do you know where I can find a current version of the ugly plugins?

    Hoyt

    P.S. Thanks for helping me again!


  • Lifetime Qt Champion

    Did you already install all the other plugin packages ?

    In any case, why not upgrade to Qt 5.9.1 ? It uses GStreamer 1.0 by default.



  • I think that upgrading is a very good suggestion. I will do so.

    Thanks again SGaist.

    hf



  • SGaist,

    I just learned that my target platform does not currently support Qt 5.9. Thus, I am still in need of a method of loading gstreamer0.10 ugly plugins on to a ubuntu derivative platform.

    Hoyt



  • From various websites, including a post from SGaist, Qt 5.8 uses gstreamer 1.0 not 0.10. I have rebuilt my target machine and loaded gstreamer 1.0 via

     sudo apt-get install gstreamer1.0
    

    This command installs the gstreamer plugins also.

    However, I am still having the identical error when trying to play a video.

     Warning: No decoder available for type 'audio/x-m4a'
     Error: Your GStreamer installation is missing a plug-in.
    

    Thus, I am still in need of assistance.

    Hoyt



  • Group,

    At least one way of solving the problem for Qt 5.8 and a ubuntu 16.04 derivative target is by the following commands:

      i)	sudo apt-get install gstreamer1.0-plugins
      ii)	sudo apt-get install gstreamer1.0-libav
    

    Hoyt


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.