No debugging information after segfault



  • Dear all,

    I can't get the debugger to run properly. When I want to explore a segmentation fault, there are apparently no debugging symbols found:

    0_1502447676648_ScreenshotQtCreator.png

    I use a Windows setup with MinGW and GDB (fresh install with the online installer).

    I highly appreciate any ideas & comments!

    Best,
    Sebastian


  • Qt Champions 2016

    Hi
    I never saw that before.

    Does it work with a default widgets GUI project?



  • Yes, it is just a mainwindow and a push button. On my Linux machine everything is fine, as well. :-/


  • Qt Champions 2016

    And you just installed mingw and using the included debugger in that binary download?



  • @mrjj yes, exactly. It is MinGW 5.3.0 32bit with GDB 7.10.1 - both came bundled with my Qt installation

    Its on Win 10 on a virtual machine, but I had this issue on other Windows machines, too.


  • Qt Champions 2016

    @SebastianH
    Hmm, normally mingw provides "just works" out of the box.

    Could there be any virus scanner interfering with the installation?

    Also does it work in any project or does it never ever show debug info?



  • @mrjj I installed this Win 10 machine just to explore this issue and i did not install a virus scanner.

    This only happens when the program segfaults. When i interrupt it with a breakpoint, everything ist fine.

    Sebastian


  • Qt Champions 2016

    @SebastianH
    Ah, but if you segfault outside the code, ( as in a dll) that is normal.
    Have you tried single stepping to know where in code it faults?



  • @mrjj Yes, I used the following code to provoke a segfault:

    int arr[100];
    for (int i = 0; i < 1000; i++)
        arr[i] = i;
    

    The purpose of this code is just to find out why GDB does not work as expected.

    Best,
    Sebastian



  • I tried to investigate the issue further and figured out the following:

    • it seems to be a problem with gdb and its disassembler
      • when I start gdb in the console, it doesn't show me where the crash occurs, too
      • in the debugger log, I get an error message "Disassembler failed"
    • I tried also on another VM (Win 10, also) and a Win 7 Desktop and it works on the VM, however not on the Desktop and my first VM. I have no clue what the differences between these installations are :-(

    Is anyone aware of any Windows/Qt/MinGW settings that could make the disassembler fail?

    Thanks for any ideas,
    Sebastian


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.