Android libqtforandroid.so load failed: cannot locate symbol



  • I'm trying to run my qt-android app on the Google Nexus device, it successfully compiled for armv7-arch, but when I run it, in "Application Output" under QtCreator, I get:

    E/dalvikvm( 1545): 
    dlopen("/data/data/com.joyfullmagic.rainbow/plugins/platforms/android/libqtforandroid.so") 
    failed: Cannot load library: soinfo_relocate(linker.cpp:975): 
    cannot locate symbol "_ZN22QWindowSystemInterface17handleExposeEventEP7QWindowRK7QRegion" 
    referenced by "libqtforandroid.so"...
    

    What is the reason of this error?


  • Moderators

    @johonde

    Hi and welcome to devnet

    How do you try to run your application?

    When it is compiled for armv7, you can run it only on such a device. Either you have an AVD or you need to run it on the actual device.



  • This post is deleted!


  • @koahnig

    Hi, and thanks for greetings.

    I run my app on Galaxy Nexus device, which has Cortex-A9 processor with armv7 architecture. The reason is in other.



  • Just a thought: When some function is not found, there could be a problem in deploying Qt to the device. Check that your deployment method copies Qt to the device with the application.
    Another thought: You don't tell the Qt version. If not 5.9, you should update to that. Perhaps this problem has been fixed.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.