[SOLVED] Symbian security issues in Qt/QML app



  • hi guys,
    I'm writing a Qt/Qml/SymbianC++ app for system tweaking...

    but I am facing a problem...

    I am trying to create a new cenrep key in 0x200159ED repository, but Symbian won't let me :) CRepository::Create returns -46 (KErrPermissionDenied) and I can't understand why...

    my app has 19 caps (ALL -TCB) and I can successfully modify values of existent keys in 0x200159ED repository...Get and Set works correctly on existent keys of the same repository...no permission denied.

    I have tried using the Set function (which should create a new key in case the one you tried to set does not exist) and the Create function...

    both returns -46 when I try to create a new key...

    Does anybody have any idea? or maybe I should ask Forum Nokia?

    Thanks in advance,
    faenil


  • Moderators

    If it's not Qt-specific, Forum Nokia would probably be your best bet.



  • well it could be Qt specific in the case dll libraries caps on Symbian are the problem :)

    anyway, I have posted in Forum Nokia too now, thanks for the advice ;)



  • solved by myself ;)

    turned out that when cap_wr is not specified after [Platsec] tag in the .txt cenrep file,
    it defaults to alwaysfail.

    And that's why I was not able to create the new key ;)

    Hope this will be useful to the people who will have the same problem :)



  • If you consider the issue solved, please change the thread's title so that it begins with [SOLVED]



  • done, thanks :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.