Qt Creator ignores my provisioning profile in iOS Settings



  • I've successfully run iOS examples and I've implemented my own iOS apps. There is a little annoying problem with Qt Creator is the fact that it ignores my provisioning profile and it generates an automatic provisioning profile based on the project's name. In Development team, I've set my own and I check Automatically manage signing option with no luck. It just ignores it. A workaround solution is to open the generated Xcode project and modify the provisioning profile and come back to Qt Creator and run the app with no complain. My question is how to tell Qt Creator to pick up a specific provisioning profile? I'm using Qt 5.8 and Xcode 8 with macOS Sierra. Thank you.



  • For me the following settings are working for me in the *.pro file:

    ios{
        #got this value from a xcode project (by opening the *.pbxproj
        #file with a normal editor and looking for the "Development" team
        #value)
        MY_DEVELOPMENT_TEAM.value = XXXXXXXXXX
        MY_DEVELOPMENT_TEAM.name = DEVELOPMENT_TEAM
        QMAKE_MAC_XCODE_SETTINGS += MY_DEVELOPMENT_TEAM
    }
    

    (tested with Qt 5.7.1)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.