How to configure qt with bluetooth and location modules?



  • I am building Qt 5.9.0 from source with the following configure command:

    ../qt5/configure -static -v -opensource -nomake examples -nomake tests -force-debug-info -debug -opensource -confirm-license -qml-debug -syslog -prefix /opt/Qt5.9_static_June14
    

    I would like to have the bluetooth and gps (qt-location) modules as well, but they are not being configured. Am I missing some dependancies? I am building on a 64bit Ubuntu Linux 16.04. Any help is much appreciated!

    The configure summary is as follows:

    Configure summary:
    
    Build type: linux-g++ (x86_64, CPU features: mmx sse sse2)
    Configuration: use_gold_linker sse2 sse3 ssse3 sse4_1 sse4_2 avx avx2 avx512f avx512bw avx512cd avx512dq avx512er avx512ifma avx512pf avx512vbmi avx512vl compile_examples enable_new_dtags force_debug_info largefile precompile_header accessibility debug c++11 c++14 c++1z concurrent dbus mremap reduce_exports reduce_relocations release_tools static stl
    Build options:
      Mode ................................... debug; optimized tools
      Building shared libraries .............. no
      Using C++ standard ..................... C++1z
      Using gold linker ...................... yes
      Using new DTAGS ........................ yes
      Using precompiled headers .............. yes
      Using LTCG ............................. no
      Target compiler supports:
        SSE .................................. SSE2 SSE3 SSSE3 SSE4.1 SSE4.2
        AVX .................................. AVX AVX2
        AVX512 ............................... F ER CD PF DQ BW VL IFMA VBMI
      Build parts ............................ libs tools
    Qt modules and options:
      Qt Concurrent .......................... yes
      Qt D-Bus ............................... yes
      Qt D-Bus directly linked to libdbus .... yes
      Qt Gui ................................. yes
      Qt Network ............................. yes
      Qt Sql ................................. yes
      Qt Testlib ............................. yes
      Qt Widgets ............................. yes
      Qt Xml ................................. yes
    Support enabled for:
      Accessibility .......................... yes
      Using pkg-config ....................... yes
      QML debugging .......................... yes
      udev ................................... yes
      Using system zlib ...................... yes
    Qt Core:
      DoubleConversion ....................... yes
        Using system DoubleConversion ........ no
      GLib ................................... yes
      iconv .................................. no
      ICU .................................... yes
      Logging backends:
        journald ............................. no
        syslog ............................... yes
        slog2 ................................ no
      Using system PCRE ...................... yes
    Qt Network:
      getaddrinfo() .......................... yes
      getifaddrs() ........................... yes
      IPv6 ifname ............................ yes
      libproxy ............................... no
      OpenSSL ................................ yes
        Qt directly linked to OpenSSL ........ no
      SCTP ................................... no
      Use system proxies ..................... yes
    Qt Sql:
      DB2 (IBM) .............................. no
      InterBase .............................. no
      MySql .................................. no
      OCI (Oracle) ........................... no
      ODBC ................................... no
      PostgreSQL ............................. no
      SQLite2 ................................ no
      SQLite ................................. yes
        Using system provided SQLite ......... no
      TDS (Sybase) ........................... no
    Qt Gui:
      FreeType ............................... yes
        Using system FreeType ................ yes
      HarfBuzz ............................... yes
        Using system HarfBuzz ................ yes
      Fontconfig ............................. yes
      Image formats:
        GIF .................................. yes
        ICO .................................. yes
        JPEG ................................. yes
          Using system libjpeg ............... no
        PNG .................................. yes
          Using system libpng ................ yes
      OpenGL:
        EGL .................................. yes
        Desktop OpenGL ....................... yes
        OpenGL ES 2.0 ........................ no
        OpenGL ES 3.0 ........................ no
        OpenGL ES 3.1 ........................ no
      Session Management ..................... yes
    Features used by QPA backends:
      evdev .................................. yes
      libinput ............................... yes
      mtdev .................................. no
      tslib .................................. no
      xkbcommon-evdev ........................ yes
    QPA backends:
      DirectFB ............................... no
      EGLFS .................................. yes
      EGLFS details:
        EGLFS i.Mx6 .......................... no
        EGLFS i.Mx6 Wayland .................. no
        EGLFS EGLDevice ...................... yes
        EGLFS GBM ............................ no
        EGLFS Mali ........................... no
        EGLFS Raspberry Pi ................... no
        EGL on X11 ........................... yes
      LinuxFB ................................ yes
      Mir client ............................. no
      X11:
        Using system-provided XCB libraries .. yes
        EGL on X11 ........................... yes
        Xinput2 .............................. yes
        XCB XKB .............................. yes
        XLib ................................. yes
        XCB render ........................... yes
        XCB GLX .............................. yes
        XCB Xlib ............................. yes
        Using system-provided xkbcommon ...... no
    Qt Widgets:
      GTK+ ................................... yes
      Styles ................................. Fusion Windows
    Qt PrintSupport:
      CUPS ................................... yes
    Qt SerialBus:
      Socket CAN ............................. yes
      Socket CAN FD .......................... yes
    QtXmlPatterns:
      XML schema support ..................... yes
    Qt QML:
      QML interpreter ........................ yes
      QML network support .................... yes
    Qt Quick:
      Direct3D 12 ............................ no
      AnimatedImage item ..................... yes
      Canvas item ............................ yes
      Support for Quick Designer ............. yes
      Flipable item .......................... yes
      GridView item .......................... yes
      ListView item .......................... yes
      Path support ........................... yes
      PathView item .......................... yes
      Positioner items ....................... yes
      ShaderEffect item ...................... yes
      Sprite item ............................ yes
    Qt Gamepad:
      SDL2 ................................... no
    Qt 3D:
      System Assimp .......................... no
    Qt Wayland Drivers:
      EGL .................................... yes
      Raspberry Pi ........................... no
      XComposite EGL ......................... yes
      XComposite GLX ......................... yes
      DRM EGL ................................ yes
      libhybris EGL .......................... no
    Qt Wayland Client ........................ yes
    Qt Wayland Compositor .................... yes
    Qt Bluetooth:
      BlueZ .................................. no
      BlueZ Low Energy ....................... no
      Linux Crypto API ....................... no
    Qt Sensors:
      sensorfw ............................... no
    Qt Multimedia:
      ALSA ................................... yes
      GStreamer 1.0 .......................... yes
      GStreamer 0.10 ......................... no
      Video for Linux ........................ yes
      OpenAL ................................. no
      PulseAudio ............................. yes
      Resource Policy (libresourceqt5) ....... no
      DirectShow ............................. no
      Windows Media Foundation ............... no
    Qt Location:
      Gypsy GPS Daemon ....................... no
      WinRT Geolocation API .................. no
    Qt WebEngine:
      Proprietary Codecs ..................... no
      Spellchecker ........................... yes
      ALSA ................................... yes
      PulseAudio ............................. yes
    

  • Moderators

    Have you tried this:

    sudo apt-get build-dep qt5-qmake
    

    Package name might be qt5-defaults or something like that, they keep changing package name apparently.



  • I tried both qt5-qmake and qt5-default and they both give the same error:

    aras@arasdev:~$ sudo apt-get build-dep qt5-qmake
    [sudo] password for aras: 
    Reading package lists... Done
    Picking 'qtbase-opensource-src' as source package instead of 'qt5-qmake'
    E: Unable to find a source package for qt5-qmake
    aras@arasdev:~$ sudo apt-get build-dep qt5-default 
    Reading package lists... Done
    Picking 'qtbase-opensource-src' as source package instead of 'qt5-default'
    E: Unable to find a source package for qt5-default
    

  • Lifetime Qt Champion

    Hi,

    IIRC, libbluetooth-dev is required for the QtBluetooth module, geoclue for the QtPositioning module and gypsy for the GPS part.



  • I have these libraries installed:

    • libgypsy-dev
    • libgeoclue-dev
    • libgeoclue-2-dev

    I just installed libbluetooth-dev and will check to see if that will help enable bluetooth support. Do you think I need to build and install either gypsy or geoclue from source code instead of installing them from apt-get repository?

    Thanks for you help!


  • Lifetime Qt Champion

    No no, there should be no need to go by hand.



  • @SGaist that worked for bluetooth! But not for gps. Here is the relevant section of output of ./configrue now:

    Qt Bluetooth:
      BlueZ .................................. yes
      BlueZ Low Energy ....................... yes
      Linux Crypto API ....................... yes
    Qt Sensors:
      sensorfw ............................... no
    Qt Multimedia:
      ALSA ................................... yes
      GStreamer 1.0 .......................... yes
      GStreamer 0.10 ......................... no
      Video for Linux ........................ yes
      OpenAL ................................. no
      PulseAudio ............................. yes
      Resource Policy (libresourceqt5) ....... no
      DirectShow ............................. no
      Windows Media Foundation ............... no
    Qt Location:
      Gypsy GPS Daemon ....................... no
      WinRT Geolocation API .................. no
    

    Can you think of any other packages I need for gps (qtlocation) support? I have installed everything that contains gypsy or geoclue in its name using synaptic package manager. I don't know how else to find out what I am missing. Thanks!


  • Lifetime Qt Champion

    Did you re-run configure from a clean state ?

    If so, please use the -v option to see why the test failed.



  • @SGaist yes i did run it in a clean directory with the -v option. Here is the test result:

    Checking for Gypsy... 
    Trying source 0 (type pkgConfig) of library gypsy ...
    + /usr/bin/pkg-config --exists --silence-errors gypsy gconf-2.0
    pkg-config did not find package.
      => source produced no result.
    test config.positioning.libraries.gypsy FAILED
    Checking for WinRT Geolocation API... 
    + cd /home/aras/Projects/Qt5.9_static_june15/qtlocation/config.tests/winrt && /home/aras/Projects/Qt5.9_static_june15/qtbase/bin/qmake "CONFIG -= qt debug_and_release app_bundle lib_bundle" "CONFIG += static use_gold_linker console" /home/aras/Projects/qt5/qtlocation/config.tests/winrt
    + cd /home/aras/Projects/Qt5.9_static_june15/qtlocation/config.tests/winrt && MAKEFLAGS= /usr/bin/make
    > g++ -c -pipe -g -std=gnu++11 -Wall -W -fPIC  -I/home/aras/Projects/qt5/qtlocation/config.tests/winrt -I. -I/home/aras/Projects/qt5/qtbase/mkspecs/linux-g++ -o main.o /home/aras/Projects/qt5/qtlocation/config.tests/winrt/main.cpp
    > /home/aras/Projects/qt5/qtlocation/config.tests/winrt/main.cpp:30:28: fatal error: windows.system.h: No such file or directory
    > compilation terminated.
    > Makefile:165: recipe for target 'main.o' failed
    > make: *** [main.o] Error 1
    test config.positioning.tests.winrt_geolocation FAILED
    


  • Here are the list of gypsy packages I have installed:

    $ dpkg -l | grep gypsy
    ii  gypsy-daemon                                    0.8-0ubuntu7                                     amd64        A GPS Multiplexing Daemon
    ii  libgypsy-dev                                    0.8-0ubuntu7                                     amd64        A GPS Multiplexing Daemon (Development Package)
    ii  libgypsy-doc                                    0.8-0ubuntu7                                     amd64        A GPS Multiplexing Daemon (HTML API Docs)
    ii  libgypsy0                                       0.8-0ubuntu7                                     amd64        A GPS Multiplexing Daemon (Library Package)
    
    

    Shouldn't the test look for gypsy-daemon and not gypsy? I do not see a package in the repositories with the name gypsy ??


  • Lifetime Qt Champion

    Can you check what pkg-config gypsy gconf-2.0 returns ?



  • @SGaist pkg-config gypsy gconf-2.0 returns nothing.


  • Lifetime Qt Champion

    Can you check whether you have /usr/lib/pkgconfig/gypsy.pc ?
    And any package related to gconf installed ?



  • @SGaist

    $ cat /usr/lib/pkgconfig/gypsy.pc
    prefix=/usr
    exec_prefix=${prefix}
    libdir=${exec_prefix}/lib
    includedir=${prefix}/include
    
    Name: gypsy
    Description: GPS multiplexer daemon
    Version: 0.8
    Cflags: -I${includedir}
    Requires: dbus-glib-1
    Libs: -L${libdir} -lgypsy
    

    There are several packages related to gconf. I have gconf-service and gconf2 installed, but gconf2-dev is not installed. Could that be it? I'll install all packages containing the word gconf and will try again. Thanks for looking into this!



  • @SGaist that fixed it!! Thank you!!!

    I installed anything that showed up when I search synaptic for gconf. With dependencies, that is a lot of packages. This is the list of everything that got installed. Any ideas which one of these packages was missing?

    2017-06-16 15:34:32 install freeglut3:amd64 <none> 2.8.1-2
    2017-06-16 15:34:32 install libdleyna-core-1.0-3:amd64 <none> 0.4.0-1
    2017-06-16 15:34:32 install libfreeradius-client2:amd64 <none> 1.1.6-7
    2017-06-16 15:34:33 install libopenni0:amd64 <none> 1.5.4.0-14
    2017-06-16 15:34:33 install libzzip-0-13:amd64 <none> 0.13.62-3
    2017-06-16 15:34:33 install python-pyparsing:all <none> 2.0.3+dfsg1-1ubuntu0.1
    2017-06-16 15:34:33 install python-cmd2:all <none> 0.6.8-1
    2017-06-16 15:34:33 install python-dogpile.core:all <none> 0.4.1+dfsg1-3
    2017-06-16 15:34:33 install python-wrapt:amd64 <none> 1.8.0-5build2
    2017-06-16 15:34:33 install auth-client-config:all <none> 0.9ubuntu1
    2017-06-16 15:34:34 install libpam-ldap:amd64 <none> 184-8.7ubuntu1
    2017-06-16 15:34:34 install libnss-ldap:amd64 <none> 265-3ubuntu2
    2017-06-16 15:34:34 install ldap-auth-client:all <none> 0.5.3
    2017-06-16 15:34:35 install ldap-auth-config:all <none> 0.5.3
    2017-06-16 15:34:35 install libdotconf0-dbg:amd64 <none> 1.3-0.2
    2017-06-16 15:34:35 install amule-common:all <none> 2.4.0~git20151120.0023527bc2-1ubuntu1
    2017-06-16 15:34:36 install libcrypto++9v5:amd64 <none> 5.6.1-9
    2017-06-16 15:34:36 install amule:amd64 <none> 2.4.0~git20151120.0023527bc2-1ubuntu1
    2017-06-16 15:34:36 install amule-utils:amd64 <none> 2.4.0~git20151120.0023527bc2-1ubuntu1
    2017-06-16 15:34:37 install amule-gnome-support:all <none> 2.4.0~git20151120.0023527bc2-1ubuntu1
    2017-06-16 15:34:37 install asterisk-config:all <none> 1:13.1.0~dfsg-1.1ubuntu4.1
    2017-06-16 15:34:37 install libiksemel3:amd64 <none> 1.4-3build1
    2017-06-16 15:34:37 install libpj2:amd64 <none> 2.1.0.0.ast20130823-1
    2017-06-16 15:34:37 install libpjlib-util2:amd64 <none> 2.1.0.0.ast20130823-1
    2017-06-16 15:34:37 install libpjmedia-audiodev2:amd64 <none> 2.1.0.0.ast20130823-1
    2017-06-16 15:34:37 install libpjnath2:amd64 <none> 2.1.0.0.ast20130823-1
    2017-06-16 15:34:37 install libpjmedia2:amd64 <none> 2.1.0.0.ast20130823-1
    2017-06-16 15:34:38 install libpjsip2:amd64 <none> 2.1.0.0.ast20130823-1
    2017-06-16 15:34:38 install libpjsip-simple2:amd64 <none> 2.1.0.0.ast20130823-1
    2017-06-16 15:34:38 install libpjsip-ua2:amd64 <none> 2.1.0.0.ast20130823-1
    2017-06-16 15:34:38 install libresample1:amd64 <none> 0.1.3-4
    2017-06-16 15:34:38 install asterisk-modules:amd64 <none> 1:13.1.0~dfsg-1.1ubuntu4.1
    2017-06-16 15:34:38 install asterisk-core-sounds-en-gsm:all <none> 1.4.22-1
    2017-06-16 15:34:39 install asterisk-core-sounds-en:all <none> 1.4.22-1
    2017-06-16 15:34:39 install asterisk:amd64 <none> 1:13.1.0~dfsg-1.1ubuntu4.1
    2017-06-16 15:34:39 install asterisk-voicemail:amd64 <none> 1:13.1.0~dfsg-1.1ubuntu4.1
    2017-06-16 15:34:39 install cellwriter:amd64 <none> 1.3.5-1
    2017-06-16 15:34:39 install devilspie:amd64 <none> 0.23-2
    2017-06-16 15:34:39 install distro-info:amd64 <none> 0.14build1
    2017-06-16 15:34:39 install libgupnp-av-1.0-2:amd64 <none> 0.12.8-1
    2017-06-16 15:34:40 install libgupnp-dlna-2.0-3:amd64 <none> 0.10.4-1
    2017-06-16 15:34:40 install libdleyna-connector-dbus-1.0-1:amd64 <none> 0.2.0-1
    2017-06-16 15:34:40 install dleyna-server:amd64 <none> 0.4.0-1
    2017-06-16 15:34:40 install docutils-common:all <none> 0.12+dfsg-1
    2017-06-16 15:34:40 install docutils-doc:all <none> 0.12+dfsg-1
    2017-06-16 15:34:40 install folks-common:all <none> 0.11.1-2build2
    2017-06-16 15:34:40 install tex-common:all <none> 6.04
    2017-06-16 15:34:41 install fonts-lmodern:all <none> 2.004.5-1
    2017-06-16 15:34:41 install fonts-texgyre:all <none> 20150923-1
    2017-06-16 15:34:42 install gconf-defaults-service:amd64 <none> 3.2.6-3ubuntu6
    2017-06-16 15:34:42 install gconf-editor:amd64 <none> 3.0.1-2ubuntu1
    2017-06-16 15:34:43 install gir1.2-accountsservice-1.0:amd64 <none> 0.6.40-2ubuntu11.3
    2017-06-16 15:34:43 install libcaribou-common:all <none> 0.4.20-1
    2017-06-16 15:34:43 install libcaribou0:amd64 <none> 0.4.20-1
    2017-06-16 15:34:43 install gir1.2-caribou-1.0:amd64 <none> 0.4.20-1
    2017-06-16 15:34:44 install gir1.2-cogl-1.0:amd64 <none> 1.22.0-2
    2017-06-16 15:34:44 install gir1.2-coglpango-1.0:amd64 <none> 1.22.0-2
    2017-06-16 15:34:44 install gir1.2-clutter-1.0:amd64 <none> 1.24.2-1
    2017-06-16 15:34:44 install gir1.2-gck-1:amd64 <none> 3.18.0-1ubuntu1
    2017-06-16 15:34:44 install gir1.2-gcr-3:amd64 <none> 3.18.0-1ubuntu1
    2017-06-16 15:34:44 install gir1.2-gdesktopenums-3.0:amd64 <none> 3.18.1-1ubuntu1
    2017-06-16 15:34:44 install libgdm1:amd64 <none> 3.18.3-0ubuntu2.1
    2017-06-16 15:34:45 install gir1.2-gdm-1.0:amd64 <none> 3.18.3-0ubuntu2.1
    2017-06-16 15:34:45 install gir1.2-xkl-1.0:amd64 <none> 5.4-0ubuntu2
    2017-06-16 15:34:45 install gir1.2-gkbd-3.0:amd64 <none> 3.6.0-1ubuntu2
    2017-06-16 15:34:45 install gir1.2-gnomebluetooth-1.0:amd64 <none> 3.18.2-1ubuntu2
    2017-06-16 15:34:45 install gir1.2-gnomedesktop-3.0:amd64 <none> 3.18.2-1ubuntu1
    2017-06-16 15:34:45 install gir1.2-gweather-3.0:amd64 <none> 3.18.2-0ubuntu0.1
    2017-06-16 15:34:45 install mutter-common:all <none> 3.18.3-0ubuntu2
    2017-06-16 15:34:45 install libmutter0g:amd64 <none> 3.18.3-0ubuntu2
    2017-06-16 15:34:46 install gir1.2-mutter-3.0:amd64 <none> 3.18.3-0ubuntu2
    2017-06-16 15:34:46 install gir1.2-networkmanager-1.0:amd64 <none> 1.2.6-0ubuntu0.16.04.1
    2017-06-16 15:34:46 install gir1.2-nmgtk-1.0:amd64 <none> 1.2.6-0ubuntu0.16.04.3
    2017-06-16 15:34:46 install gir1.2-polkit-1.0:amd64 <none> 0.105-14.1
    2017-06-16 15:34:46 install gir1.2-telepathyglib-0.12:amd64 <none> 0.24.1-1.1
    2017-06-16 15:34:46 install gir1.2-telepathylogger-0.2:amd64 <none> 0.8.2-1
    2017-06-16 15:34:46 install gir1.2-upowerglib-1.0:amd64 <none> 0.99.4-2ubuntu0.3
    2017-06-16 15:34:46 install gnome-backgrounds:all <none> 3.18.0-1
    2017-06-16 15:34:47 install libchamplain-0.12-0:amd64 <none> 0.12.13-1
    2017-06-16 15:34:47 install libfolks25:amd64 <none> 0.11.1-2build2
    2017-06-16 15:34:47 install libfolks-eds25:amd64 <none> 0.11.1-2build2
    2017-06-16 15:34:47 install libfolks-telepathy25:amd64 <none> 0.11.1-2build2
    2017-06-16 15:34:48 install gnome-contacts:amd64 <none> 3.18.1-1ubuntu3
    2017-06-16 15:34:48 install libcolord-gtk1:amd64 <none> 0.1.26-1
    2017-06-16 15:34:48 install libgoa-backend-1.0-1:amd64 <none> 3.18.3-1ubuntu2
    2017-06-16 15:34:48 install gnome-control-center-data:all <none> 1:3.18.2-1ubuntu6
    2017-06-16 15:34:48 install gnome-settings-daemon:amd64 <none> 3.18.2-0ubuntu3.1
    2017-06-16 15:34:49 install gnome-control-center:amd64 <none> 1:3.18.2-1ubuntu6
    2017-06-16 15:34:49 install gnome-online-accounts:amd64 <none> 3.18.3-1ubuntu2
    2017-06-16 15:34:49 install gnome-session:all <none> 3.18.1.2-1ubuntu1.16.04.2
    2017-06-16 15:34:49 install gnome-themes-standard-data:all <none> 3.18.0-2ubuntu1
    2017-06-16 15:34:49 install libgwrap-runtime2:amd64 <none> 1.9.15-0.1
    2017-06-16 15:34:49 install guile-g-wrap:amd64 <none> 1.9.15-0.1
    2017-06-16 15:34:49 install hdhomerun-config:amd64 <none> 20150826-2
    2017-06-16 15:34:50 install human-theme:all <none> 0.39.2
    2017-06-16 15:34:50 install krb5-config:all <none> 2.3
    2017-06-16 15:34:50 install libb-hooks-op-check-perl:amd64 <none> 0.19-2build2
    2017-06-16 15:34:50 install liblexical-sealrequirehints-perl:amd64 <none> 0.009-1build1
    2017-06-16 15:34:50 install libbareword-filehandles-perl:amd64 <none> 0.003-1build3
    2017-06-16 15:34:50 install libburn-dev:amd64 <none> 1.4.2.pl01-1
    2017-06-16 15:34:50 install libcaribou-gtk-module:amd64 <none> 0.4.20-1
    2017-06-16 15:34:50 install libcaribou-gtk3-module:amd64 <none> 0.4.20-1
    2017-06-16 15:34:51 install libglobus-common0:amd64 <none> 16.0-2
    2017-06-16 15:34:51 install libglobus-gsi-openssl-error0:amd64 <none> 3.5-5
    2017-06-16 15:34:51 install libglobus-gsi-proxy-ssl1:amd64 <none> 5.7-5
    2017-06-16 15:34:51 install libglobus-openssl-module0:amd64 <none> 4.6-5
    2017-06-16 15:34:51 install libglobus-gsi-cert-utils0:amd64 <none> 9.11-2
    2017-06-16 15:34:51 install libglobus-gsi-sysconfig1:amd64 <none> 6.9-2
    2017-06-16 15:34:51 install libglobus-gsi-callback0:amd64 <none> 5.8-2
    2017-06-16 15:34:52 install libglobus-gsi-credential1:amd64 <none> 7.9-2
    2017-06-16 15:34:52 install libglobus-callout0:amd64 <none> 3.13-5
    2017-06-16 15:34:52 install libglobus-gsi-proxy-core0:amd64 <none> 7.9-2
    2017-06-16 15:34:52 install libglobus-gssapi-gsi4:amd64 <none> 11.26-2
    2017-06-16 15:34:52 install libglobus-gss-assist3:amd64 <none> 10.15-2
    2017-06-16 15:34:52 install libvomsapi1v5:amd64 <none> 2.0.12-4build1
    2017-06-16 15:34:52 install libgsoap8:amd64 <none> 2.8.28-1
    2017-06-16 15:34:52 install libcgsi-gsoap1:amd64 <none> 1.3.8-1build1
    2017-06-16 15:34:53 install libclass-xsaccessor-perl:amd64 <none> 1.19-2build4
    2017-06-16 15:34:53 install libsub-exporter-progressive-perl:all <none> 0.001011-1
    2017-06-16 15:34:53 install libdevel-globaldestruction-perl:all <none> 0.13-1
    2017-06-16 15:34:53 install libimport-into-perl:all <none> 1.002005-1
    2017-06-16 15:34:53 install librole-tiny-perl:all <none> 2.000001-2
    2017-06-16 15:34:53 install libstrictures-perl:all <none> 2.000002-1
    2017-06-16 15:34:53 install libmoo-perl:all <none> 2.000002-1
    2017-06-16 15:34:53 install libmoox-types-mooselike-perl:all <none> 0.29-1
    2017-06-16 15:34:54 install libconfig-gitlike-perl:all <none> 1.16-1
    2017-06-16 15:34:54 install libcppunit-subunit0:amd64 <none> 1.1.0-3
    2017-06-16 15:34:54 install libcppunit-subunit-dev:amd64 <none> 1.1.0-3
    2017-06-16 15:34:54 install libcurl4-gnutls-dev:amd64 <none> 7.47.0-1ubuntu2.2
    2017-06-16 15:34:54 install libdapserver7v5:amd64 <none> 3.15.1-7
    2017-06-16 15:34:54 install uuid-dev:amd64 <none> 2.27.1-6ubuntu3.2
    2017-06-16 15:34:54 install pkgconf:amd64 <none> 0.9.12-1
    2017-06-16 15:34:55 install libdap-dev:amd64 <none> 3.15.1-7
    2017-06-16 15:34:55 install libfile-homedir-perl:all <none> 1.00-1
    2017-06-16 15:34:55 install libfltk1.3:amd64 <none> 1.3.3-7
    2017-06-16 15:34:55 install libgconf-bridge0:amd64 <none> 0.1-2.2ubuntu1
    2017-06-16 15:34:56 install libgconf2-dev:amd64 <none> 3.2.6-3ubuntu6
    2017-06-16 15:34:56 install libgconf-bridge-dev:amd64 <none> 0.1-2.2ubuntu1
    2017-06-16 15:34:56 install libgconf2-4:amd64 <none> 3.2.6-3ubuntu6
    2017-06-16 15:34:56 install libgconf2-doc:all <none> 3.2.6-3ubuntu6
    2017-06-16 15:34:56 install libglib2.0-cil:amd64 <none> 2.12.10-6
    2017-06-16 15:34:56 install libgconf2.0-cil:all <none> 2.24.2-4
    2017-06-16 15:34:56 install libgconf2.0-cil-dev:all <none> 2.24.2-4
    2017-06-16 15:34:56 install libgconfmm-2.6-1v5:amd64 <none> 2.28.3-0ubuntu3
    2017-06-16 15:34:56 install libgtkmm-2.4-dev:amd64 <none> 1:2.24.4-2
    2017-06-16 15:34:57 install libgconfmm-2.6-dev:amd64 <none> 2.28.3-0ubuntu3
    2017-06-16 15:34:57 install libgconfmm-2.6-doc:all <none> 2.28.3-0ubuntu3
    2017-06-16 15:34:57 install libgfal-srm-ifce1:amd64 <none> 1.23.3-1build1
    2017-06-16 15:34:57 install libmozjs-24-0v5:amd64 <none> 24.2.0-3ubuntu2
    2017-06-16 15:34:57 install libgjs0e:amd64 <none> 1.44.0-1ubuntu1
    2017-06-16 15:34:58 install libindirect-perl:amd64 <none> 0.36-1build1
    2017-06-16 15:34:58 install libisoburn1:amd64 <none> 1.4.2-4ubuntu1
    2017-06-16 15:34:58 install libisofs-dev:amd64 <none> 1.4.2-2
    2017-06-16 15:34:58 install libisoburn-dev:amd64 <none> 1.4.2-4ubuntu1
    2017-06-16 15:34:58 install libjs-sphinxdoc:all <none> 1.3.6-2ubuntu1.1
    2017-06-16 15:34:58 install lxc-common:amd64 <none> 2.0.7-0ubuntu1~16.04.2
    2017-06-16 15:34:58 install liblxc1:amd64 <none> 2.0.7-0ubuntu1~16.04.2
    2017-06-16 15:34:59 install libmultidimensional-perl:amd64 <none> 0.010-1build3
    2017-06-16 15:34:59 install libnl-3-dev:amd64 <none> 3.2.27-1ubuntu0.16.04.1
    2017-06-16 15:34:59 install libnl-genl-3-dev:amd64 <none> 3.2.27-1ubuntu0.16.04.1
    2017-06-16 15:34:59 install libopenni-dev:amd64 <none> 1.5.4.0-14
    2017-06-16 15:34:59 install openni-utils:amd64 <none> 1.5.4.0-14
    2017-06-16 15:34:59 install libopenni-sensor-pointclouds0:amd64 <none> 5.1.0.41.5-1
    2017-06-16 15:34:59 install libpam-cgfs:amd64 <none> 2.0.7-0ubuntu1~16.04.1
    2017-06-16 15:34:59 install libpkgconfig-perl:all <none> 0.11026-1
    2017-06-16 15:35:00 install libpotrace0:amd64 <none> 1.13-2
    2017-06-16 15:35:00 install libptexenc1:amd64 <none> 2015.20160222.37495-1
    2017-06-16 15:35:00 install libqtgconf1:amd64 <none> 0.1-0ubuntu5
    2017-06-16 15:35:00 install libqtgconf-dev:amd64 <none> 0.1-0ubuntu5
    2017-06-16 15:35:00 install libqtxdg0:amd64 <none> 0.5.2-4build1
    2017-06-16 15:35:00 install libradcli4:amd64 <none> 1.2.4-2.1
    2017-06-16 15:35:00 install librazorqt0:amd64 <none> 0.5.2-4build1
    2017-06-16 15:35:00 install libsubunit0:amd64 <none> 1.1.0-3
    2017-06-16 15:35:01 install libsubunit-dev:amd64 <none> 1.1.0-3
    2017-06-16 15:35:01 install libsx0:amd64 <none> 2.05-7
    2017-06-16 15:35:01 install libsx-dev:amd64 <none> 2.05-7
    2017-06-16 15:35:01 install libsynctex1:amd64 <none> 2015.20160222.37495-1
    2017-06-16 15:35:01 install libtexlua52:amd64 <none> 2015.20160222.37495-1
    2017-06-16 15:35:01 install libtexluajit2:amd64 <none> 2015.20160222.37495-1
    2017-06-16 15:35:01 install libwvstreams4.6-base:amd64 <none> 4.6.1-7
    2017-06-16 15:35:01 install libwvstreams4.6-extras:amd64 <none> 4.6.1-7
    2017-06-16 15:35:02 install libuniconf4.6:amd64 <none> 4.6.1-7
    2017-06-16 15:35:02 install libxt-dev:amd64 <none> 1:1.1.5-0ubuntu1
    2017-06-16 15:35:02 install libxmu-headers:all <none> 2:1.1.2-2
    2017-06-16 15:35:02 install libxmu-dev:amd64 <none> 2:1.1.2-2
    2017-06-16 15:35:02 install libxpm-dev:amd64 <none> 1:3.5.11-1ubuntu0.16.04.1
    2017-06-16 15:35:02 install libxaw7-dev:amd64 <none> 2:1.0.13-1
    2017-06-16 15:35:02 install lmodern:all <none> 2.004.5-1
    2017-06-16 15:35:03 install python3-lxc:amd64 <none> 2.0.7-0ubuntu1~16.04.2
    2017-06-16 15:35:03 install lxc1:amd64 <none> 2.0.7-0ubuntu1~16.04.2
    2017-06-16 15:35:04 install lxc:all <none> 2.0.7-0ubuntu1~16.04.2
    2017-06-16 15:35:04 install lxc-android-config:all <none> 0.230+16.04.20160328-0ubuntu1
    2017-06-16 15:35:04 install lxc-templates:amd64 <none> 2.0.7-0ubuntu1~16.04.2
    2017-06-16 15:35:04 install lxcfs:amd64 <none> 2.0.7-0ubuntu1~16.04.1
    2017-06-16 15:35:04 install neard-dev:amd64 <none> 0.11-1
    2017-06-16 15:35:04 install preview-latex-style:all <none> 11.88-1.1ubuntu1
    2017-06-16 15:35:04 install texlive-binaries:amd64 <none> 2015.20160222.37495-1
    2017-06-16 15:35:05 install texlive-base:all <none> 2015.20160320-1
    2017-06-16 15:35:07 install texlive-latex-base:all <none> 2015.20160320-1
    2017-06-16 15:35:07 install texlive-latex-recommended:all <none> 2015.20160320-1
    2017-06-16 15:35:08 install texlive-pictures:all <none> 2015.20160320-1
    2017-06-16 15:35:09 install texlive-generic-recommended:all <none> 2015.20160320-1
    2017-06-16 15:35:09 install texlive-pstricks:all <none> 2015.20160320-1
    2017-06-16 15:35:10 install prosper:all <none> 1.00.4+cvs.2007.05.01-4
    2017-06-16 15:35:10 install ps2eps:amd64 <none> 1.68+binaryfree-1
    2017-06-16 15:35:10 install pulseaudio-module-gconf:amd64 <none> 1:8.0-0ubuntu3.2
    2017-06-16 15:35:11 install python-appdirs:all <none> 1.4.0-2
    2017-06-16 15:35:11 install python-attr:all <none> 15.2.0-1
    2017-06-16 15:35:11 install python-babel-localedata:all <none> 1.3+dfsg.1-6
    2017-06-16 15:35:11 install python-tz:all <none> 2014.10~dfsg1-0ubuntu2
    2017-06-16 15:35:11 install python-babel:all <none> 1.3+dfsg.1-6
    2017-06-16 15:35:11 install python-pbr:all <none> 1.8.0-4ubuntu1
    2017-06-16 15:35:12 install python-funcsigs:all <none> 0.4-2
    2017-06-16 15:35:12 install python-debtcollector:all <none> 1.3.0-2
    2017-06-16 15:35:12 install python-iso8601:all <none> 0.1.11-1
    2017-06-16 15:35:12 install python-keyring:all <none> 7.3-1ubuntu1
    2017-06-16 15:35:12 install python-positional:all <none> 1.0.1-2
    2017-06-16 15:35:12 install python-stevedore:all <none> 1.12.0-1
    2017-06-16 15:35:12 install python-keystoneauth1:all <none> 2.4.1-1ubuntu0.16.04.1
    2017-06-16 15:35:12 install python-roman:all <none> 2.0.0-2
    2017-06-16 15:35:13 install python-docutils:all <none> 0.12+dfsg-1
    2017-06-16 15:35:13 install python-netaddr:all <none> 0.7.18-1
    2017-06-16 15:35:13 install python-oslo.config:all <none> 1:3.9.0-3
    2017-06-16 15:35:13 install python-oslo.i18n:all <none> 3.5.0-2
    2017-06-16 15:35:13 install python-msgpack:amd64 <none> 0.4.6-1build1
    2017-06-16 15:35:13 install python-monotonic:all <none> 0.6-2
    2017-06-16 15:35:14 install python-netifaces:amd64 <none> 0.10.4-0.1build2
    2017-06-16 15:35:14 install python-oslo.utils:all <none> 3.8.0-2
    2017-06-16 15:35:14 install python-oslo.serialization:all <none> 2.4.0-2
    2017-06-16 15:35:14 install python-prettytable:all <none> 0.7.2-3
    2017-06-16 15:35:14 install python-keystoneclient:all <none> 1:2.3.1-2
    2017-06-16 15:35:14 install python-simplejson:amd64 <none> 3.8.1-1ubuntu2
    2017-06-16 15:35:14 install python-cinderclient:all <none> 1:1.6.0-2
    2017-06-16 15:35:15 install python-unicodecsv:all <none> 0.14.1-1
    2017-06-16 15:35:15 install python-yaml:amd64 <none> 3.11-3build1
    2017-06-16 15:35:15 install python-cliff:all <none> 1.15.0-2ubuntu2
    2017-06-16 15:35:15 install python-dogpile.cache:all <none> 0.5.7-1ubuntu1
    2017-06-16 15:35:15 install python-twisted-bin:amd64 <none> 16.0.0-1
    2017-06-16 15:35:15 install python-zope.interface:amd64 <none> 4.1.3-1build1
    2017-06-16 15:35:15 install python-pyasn1-modules:all <none> 0.0.7-0.1
    2017-06-16 15:35:15 install python-service-identity:all <none> 16.0.0-2
    2017-06-16 15:35:15 install python-twisted-core:all <none> 16.0.0-1
    2017-06-16 15:35:16 install python-twisted:all <none> 16.0.0-1
    2017-06-16 15:35:16 install python-epsilon:all <none> 0.7.1-1
    2017-06-16 15:35:16 install python-functools32:all <none> 3.2.3.2-2
    2017-06-16 15:35:16 install python-json-pointer:all <none> 1.9-3
    2017-06-16 15:35:17 install python-jsonpatch:all <none> 1.19-3
    2017-06-16 15:35:17 install python-mock:all <none> 1.3.0-2.1ubuntu1
    2017-06-16 15:35:17 install python-jsonschema:all <none> 2.5.1-4
    2017-06-16 15:35:17 install python-warlock:all <none> 1.1.0-1
    2017-06-16 15:35:17 install python-glanceclient:all <none> 1:2.0.0-2ubuntu0.16.04.1
    2017-06-16 15:35:17 install python-requestsexceptions:all <none> 1.1.2-0ubuntu1
    2017-06-16 15:35:17 install python-os-client-config:all <none> 1.16.0-0ubuntu1
    2017-06-16 15:35:17 install python-neutronclient:all <none> 1:4.1.1-2
    2017-06-16 15:35:18 install python-novaclient:all <none> 2:3.3.1-2ubuntu1
    2017-06-16 15:35:18 install python-openstacksdk:all <none> 0.8.1-2
    2017-06-16 15:35:18 install python-openstackclient:all <none> 2.3.0-2
    2017-06-16 15:35:18 install python-ironicclient:all <none> 1.2.0-2
    2017-06-16 15:35:18 install python-m2crypto:amd64 <none> 0.22.6~rc4-1ubuntu1
    2017-06-16 15:35:18 install python-nose:all <none> 1.3.7-1
    2017-06-16 15:35:18 install python-messaging:all <none> 0.5.12+debian-2
    2017-06-16 15:35:19 install python-os-cloud-config:all <none> 0.2.6-1
    2017-06-16 15:35:19 install python-pam:amd64 <none> 0.4.2-13.2ubuntu2
    2017-06-16 15:35:19 install python-pkgconfig:all <none> 1.1.0-1
    2017-06-16 15:35:19 install python-pygments:all <none> 2.1+dfsg-1
    2017-06-16 15:35:19 install python-secretstorage:all <none> 2.1.3-1
    2017-06-16 15:35:19 install python-serial:all <none> 3.0.1-1
    2017-06-16 15:35:19 install python-wader:all <none> 0.5.13-1
    2017-06-16 15:35:20 install python3-pkgconfig:all <none> 1.1.0-1
    2017-06-16 15:35:20 install qt4-qtconfig:amd64 <none> 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1
    2017-06-16 15:35:20 install razorqt-data:all <none> 0.5.2-4build1
    2017-06-16 15:35:20 install razorqt-config:amd64 <none> 0.5.2-4build1
    2017-06-16 15:35:20 install realmd:amd64 <none> 0.16.2-2
    2017-06-16 15:35:20 install sox:amd64 <none> 14.4.1-5
    2017-06-16 15:35:21 install srm-ifce-dev:amd64 <none> 1.23.3-1build1
    2017-06-16 15:35:21 install tex-gyre:all <none> 20150923-1
    2017-06-16 15:35:21 install texlive-extra-utils:all <none> 2015.20160320-1
    2017-06-16 15:35:22 install texlive-font-utils:all <none> 2015.20160320-1
    2017-06-16 15:35:23 install texlive-fonts-recommended:all <none> 2015.20160320-1
    2017-06-16 15:35:23 install texlive-fonts-recommended-doc:all <none> 2015.20160320-1
    2017-06-16 15:35:24 install texlive-latex-base-doc:all <none> 2015.20160320-1
    2017-06-16 15:35:27 install texlive-latex-extra:all <none> 2015.20160320-1
    2017-06-16 15:35:29 install texlive-latex-extra-doc:all <none> 2015.20160320-1
    2017-06-16 15:35:53 install texlive-latex-recommended-doc:all <none> 2015.20160320-1
    2017-06-16 15:35:56 install texlive-pictures-doc:all <none> 2015.20160320-1
    2017-06-16 15:36:03 install texlive-pstricks-doc:all <none> 2015.20160320-1
    2017-06-16 15:36:08 install texlive-publishers:all <none> 2015.20160320-1
    2017-06-16 15:36:09 install texlive-publishers-doc:all <none> 2015.20160320-1
    2017-06-16 15:36:15 install tipa:all <none> 2:1.3-20
    2017-06-16 15:36:15 install ttf-dejavu-core:all <none> 2.35-1
    2017-06-16 15:36:16 install tuxpaint-config:amd64 <none> 0.0.13-1
    2017-06-16 15:36:16 install ubuntu-core-config:all <none> 0.6.40
    2017-06-16 15:36:16 install uidmap:amd64 <none> 1:4.2-3.1ubuntu5.3
    2017-06-16 15:36:16 install vim-syntax-gtk:all <none> 20110314-1
    2017-06-16 15:36:16 install xserver-xephyr:amd64 <none> 2:1.18.4-0ubuntu0.2
    2017-06-16 15:36:16 install asterisk-moh-opsound-gsm:all <none> 2.03-1
    2017-06-16 15:36:16 install cloud-image-utils:all <none> 0.27-0ubuntu24
    2017-06-16 15:36:17 install debootstrap:all <none> 1.0.78+nmu1ubuntu1.3
    2017-06-16 15:36:17 install exim4-config:all <none> 4.86.2-2ubuntu2.1
    2017-06-16 15:36:17 install gjs:amd64 <none> 1.44.0-1ubuntu1
    2017-06-16 15:36:17 install guile-gnome2-glib:amd64 <none> 2.16.2-2
    2017-06-16 15:36:17 install guile-gnome2-gconf:amd64 <none> 2.16.2-2
    2017-06-16 15:36:17 install libcaribou-dbg:amd64 <none> 0.4.20-1
    2017-06-16 15:36:17 install libcaribou-gtk-module-dbg:amd64 <none> 0.4.20-1
    2017-06-16 15:36:17 install libcaribou-gtk3-module-dbg:amd64 <none> 0.4.20-1
    2017-06-16 15:36:18 install libgopersist-1-1:amd64 <none> 0.1.1-0ubuntu4
    2017-06-16 15:36:18 install libgopersist-1-1-dbg:amd64 <none> 0.1.1-0ubuntu4
    2017-06-16 15:36:18 install libgopersist-1-dev:amd64 <none> 0.1.1-0ubuntu4
    2017-06-16 15:36:18 install libresiprocate-1.10:amd64 <none> 1:1.10.1-2ubuntu1
    2017-06-16 15:36:18 install mutter:amd64 <none> 3.18.3-0ubuntu2
    2017-06-16 15:36:18 install sipdialer:amd64 <none> 1:1.10.1-2ubuntu1
    2017-06-16 15:36:18 install vim-addon-manager:all <none> 0.5.5
    2017-06-16 15:36:19 install xautomation:amd64 <none> 1.09-1
    

  • Lifetime Qt Champion

    You're welcome !

    I'm pretty sure not all these packages are necessary but at least you have it working now :)



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.