Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

| ERROR | Cross compilation Raspberry Pi3 Windows Qt 5.9



  • Hi Community, I'm new at the forum so sorry for my mistakes.

    I'm doing cross compilation betwwen Windows PC and Raspberry Pi 3 with Raspbian.

    I follow instruction described there: https://forum.qt.io/topic/68381/cross-compile-qt-windows-to-raspberry-3 which is based on this: https://visualgdb.com/tutorials/raspberry/qt/embedded/

    The topic is old so I made a new one.

    I'm using qt-everywhere-opensource-src-5.9.0 and MinGw32/64

    I stuck at the step 13. My configuration command is:
    ../qt-everywhere-opensource-src-5.9.0/configure -platform win32-g++ -xplatform linux-arm-gnueabihf-g++ -release -nomake tests -nomake examples -optimized-qmake -no-opengl -device linux-rasp-pi3-g++ -sysroot C:/SysGCC/Raspberry/arm-linux-gnueabihf/sysroot -prefix /usr/local/qt5 -device-option CROSS_COMPILE=C:/SysGCC/Raspberry/bin/arm-linux-gnueabihf- -qt-xcb -opensource -confirm-license

    The output:
    "
    Preparing build tree...
    Creating qmake...
    ............................................................................................Done.
    Info: creating super cache file C:\SysGCC\qt-build.qmake.super
    ERROR: Cannot specify both -xplatform and -device.
    "

    I searched the web and couldn't find similar poroblem.
    Also I tried diffirent configuaration commands and paths to 'device' and 'xplatform' types.

    Please help, I'm out of ideas what is wrong.


Log in to reply