Qt World Summit: Submit your Presentation

MSVC2015 64bit compiler kit - installation requirements

  • Initially, I have installed Qt Creator 4.2.2 along with the latest MinGW build kits. For my current project I need to add in the 64bit MSVC2015 compiler running with Qt 5.7.1. So far I have used the MaintananceTool located under C:/Qt/MaintananceTool.exe to add in the relevant Qt dependencies to get this compiler running. Additionally, I downloaded and installed the Microsoft Build Tools 2015.

    I can get an empty test project to build using the added kit. Running it still does not work though. I am getting a 'The program has unexpectedly finished.' directly after hitting run.

    Am I missing anything here?

    (Note: I have access to licensed versions of Visual Studio, but wanted to avoid having to install it, since I do not use it as a coding environment currently. If it makes getting this all setup easier, I will install it)

  • Lifetime Qt Champion

    @Vagabond Did you configure the Kit for MSVC2015 manually? Are there any warnings/errors in this Kit? Can you try to debug the app?

  • @jsulm I had no warnings or errors for the kit. It just crashed giving only the output mentioned in my first post.
    My installation was divided only into the steps I posted. Here is a more detailed explanation.

    I.) Use MaintainanceTool.exe to add component:

    1. run C:/Qt/MaintainanceTool.exe
    2. choose add/remove component (wait for Qt to retrieve info)
    3. check Qt > Qt 5.7 > msvc2015 64-bit
    4. hit next and wait for installation to complete

    II.) Install Microsoft Build Tools 2015 (found at link in initial post)

    I went ahead and installed Visual Studio 2017 along with 2015 compiler support. Now everything works as expected. Maybe the build tools didn't install the msvc2015 compiler at the path Qt expects it to be!? My problem is solved... Not sure why MS Build tools didn't work at my first go...

  • This post is deleted!

  • Do you set the PATH on your computer? Check it from "this PC">>"Properties">>"Advandced setting">>"Enviroment V...">>"Path">>Edit

Log in to reply