QT Creator - No compiler set for any kits



  • So, I've been having this problem for a while now, and I can't seem to fix it.
    I posted same question here with (I think) another account, however no solution was found even though I followed several steps.

    My problem is that QT Creator simply won't add a compiler to the auto-detected kits, even if it also auto-detects several compilers :

    alt text

    alt text

    I'm so confused, it clearly detects the compilers, but it doesn't add them to the kits?
    And I can't seem to add them manually either since the compiler item box thingy's are grayed out :

    alt text

    What to do? I really want to finish my current project :[


  • Moderators

    Hi,

    Welcome to the forum, again ;-)

    Maybe you can start by telling us ;
    how did you install Qt
    and so on?

    Edit : I would expect to see an error on the bottom of the options dialog. Can you show it?

    Eddy


  • Moderators

    You've got Visual Studio 2017 installed (yes, the numbers don't match, but Microsoft Visual C++ Compiler 15.0 is VS2017), but you've got Qt library for Visual Studio 2015. QtCreator won't set a mixed kit like that (thus the <No compiler> in your kits).

    VS2017 can work with VS2015 Qt package, but you need to manually set up a kit for such a mix. Select any of the auto-detected kits, click "Clone" and in the new kit you'll be able to select a compiler for it.
    See my other post if you want to see it in pictures.

    The other option is to go back to MSVC 14.0 (the compiler of VS2015). You can add it through your VS2017 installer (the Vs2017 IDE then has two compilers to choose from) or install VS2015 separately. With this option QtCreator will automatically bond the kits you have with matching compiler version.



  • @Chris-Kawa I have Visual Studio 2015 Community installed as well, shouldn't Qt be detecting it automatically?
    It seems weird that it only detects my Visual Studio Community 2017 install, but not my 2015 one. o.O

    Ediiit : Turns out I forgot to install the actual C++ compiler when installing Visual Studio 2015, goddammit...
    I legit just spent a month wonder why it wasn't working....
    Well this is annoying, but on the bright side I got it working, I guess... >.<

    Thanks for the help though! ^^


Log in to reply