QtWebEngine build silently ignored on Windows



  • or I'm unable to find the error message. After jom/nmake install there is no QtWebEngine to be found in the installation directory.

    I'm configuring with

    // executed in directory E:\dev\git\qt5\build
    // qt source is in E:\dev\git\qt5
    ..\configure --prefix=E:\dev\git\qt5\build\installed -opensource -nomake tests -nomake examples -confirm-license -no-pch
    

    config.log
    config.summary

    My Visual Studio version is Visual Studio Community 2017 - 15.1 (26403.7) with Windows 10 SDK (10.0.15063.0) and Toolset for Visual C++ 2015.3 v140 installed. Qt Source is from branch 5.9.


  • Lifetime Qt Champion

    Hi,

    Did you check that you have the requirements to build QtWebEngine ?



  • Yes I have Python, Strawberry Perl, Bison, Flex and GPerf, all in PATH. Shouldn't it at least print out a notification if not so ?

    Between the first post and now I also tried to use actual Visual Studio 2015 Update 3 (but for some reason it only gave me a x86 command prompt) still silently ignored.

    Also tried to go to qtwebengine\tools\qmake\mkspecs\features and inside the file configure.prf I changed

    defineTest(runConfigure) {
    

    to

    log("bla1") # also tried: error("bla1")
    defineTest(runConfigure) {
        log("bla2") # also tried: error("bla2")
    

    I can't find the log entry anywhere and error didn't stop the entire process. I don't know much about the Qt configure/build process, I only came there from the Qt WebEngine Platform Notes.


  • Lifetime Qt Champion

    If you have the rest of Qt built properly, what you can do is to compile QtWebEngine by hand. You should then get a more detailed log of why it has failed.

    Create an empty folder and run path/to/your/qmake path/to/your/QtWebEngine_sources/



  • Thank you, compiling QtWebEngine by hand did output error messages, one being that WindowsSDKVersion environment variable was not set and the other being that "Python 2.7.5 or later" means "Python lower than 3".

    While there are still errors along the build, the original problem has been solved. QtWebEngine is starting compilation now.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.