Following symbols in Qt Creator broken



  • I have a few issues with the 'follow symbol' functionality in Qt Creator. The first one is that if I have a variable declared as 'auto', then 'follow symbol' doesn't work on any of its members (for example when it's a struct). This issue has already been reported here: https://bugreports.qt.io/browse/QTCREATORBUG-13794

    The second is that following an enum class type jumps to the forward declaration even if the full declaration is available.

    Odly enough, autocompletion works perfectly for 'auto' variables.

    I tried debugging Qt Creator, and it seems that for jumping to variable declaration it uses a library in libs/3rdparty/cplusplus, and not libclang. Is that correct?

    Any hints on how to fix these problems in Qt Creator source code would be very welcome.


  • Lifetime Qt Champion

    Hi,

    IIRC, Qt Cteator has two code models plugin the "old one" and the recent that is clang based. You should check which is activated in your Qt Creator options.

    Hope it helps



  • "The Clang Code Model is enabled because the corresponding plugin is loaded".

    I assume that this means that the older code model is inactive? Are there any other settings for it other than Optiona->C++->CodeModel?



  • I turned off the Clang Code Model plugin, and the 'follow symbol' command still works the same (in cases where it wasn't already broken before), along with 'find usages', and renaming.

    It seems that the only thing not working now is code completion. So I assume that's the only functionality that uses the clang based model.

    My question is whether it's possible to switch Qt Creator to use the clang model for all of the above and not use the 'old' model at all?


  • Lifetime Qt Champion

    Which version are you using ?



  • I've tried this in both 4.1 and 4.4-beta1 that I built from git a few days ago.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.