Call createshortcut when updating with Qt Installer FW fails



  • I am trying to make a update to my existing package. In current package there is a operation which add's a desktop shortcut pointing to my app. When running maintenance tool update the old package undo operation remove that shortcut. On new package's createOperation I only have creation of shortcut (same code than first version has), but when running from update respository this shortcut is newer seen. Old application is removed and new one is updated but shortcut is not shown. Strange is that when I run maintenance tool with -v debugging it works!

    I have tried performOperation, addOperation and addElevatedOperation to achieve this but with no success.

    UPDATE 26.4.2017: Currently I am working with QTIFW3.0 branch because I am using --silentUpdate option in maintenancetool to make update in background. Development OS is Windows 10 64bit, but Mac is also a target for deployment (but that is different story...).

    Br,
    -sami


  • Lifetime Qt Champion

    Hi,

    You should add the version of the installer framework you are using as well as target OS.



  • @SamiN This seemed to be quite straight forward to solve. I created my shortcuts under user desktop area, but when running maintenance tool from service using qtservice it most probably didn't have that 'user' setup in place so trying to add shortcut to desktop failed. Changed location of the shortcut to c:\users\public\desktop seems to help on this one.

    Br,
    -sami


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.