Problems signing an Mac App



  • Hi I'm having difficulties signing an Mac OS App, because I have some dylibs that are located in the apps plugin directory. I have had a dialog with Apple's Developer Technical Support and they are suggesting that I remove my Plugin directory and move all the dylibs from there to the Frameworks directory. The problem is that, when I do that, I can run my program, because Qt can't load the "cocoa" plugin.

    My question is: Is it possible to have a functioning application, where all the dylibs from the Plugin directory are moved to the Framework directory? Because that seems to be the only wat I can properly sign my application according to Apple's DTS.

    Thanks in advance


  • Lifetime Qt Champion

    Hi,

    What signing problem do you have exactly ?



  • My problem is that my application wont sign properly, because of my nested code.


  • Lifetime Qt Champion

    What do you mean by nested code ?



  • This is how I sign

    codesign --force --deep -vvvv -s "$SIGN_IDENTITY" $APP
    codesign --verify -vvvv $APP
    spctl --verbose=4 --assess --type execute $APP
    

    Maybe you can try that and see if it works.



  • Hi dimitar
    I tried doing the same as you and the output of the second line is:

    myAPP: valid on disk
    myAPP: satisfies its Designated Requirement

    But the output of the third line is:

    myApp: rejected
    source=Developer ID

    I used to be able to sign my apps, but for some reason it wont anymore and we renewed our developer license at Apple 1 months ago. Sp that shouldn't be the problem.

    @SGaist
    The reason I' bringing up nested code, is because of this conversation I had with an Apple tecnician: https://forums.developer.apple.com/thread/75149


  • Lifetime Qt Champion

    Then you should use the -codesign option of macdeployqt



  • I can't seem to find that option


  • Lifetime Qt Champion

    What version of Qt are you using ?



  • http://imageshack.com/a/img922/6973/y8ThDu.png


  • Lifetime Qt Champion

    That's the Qt Creator version. What is the installed Qt version ?



  • I'm using version 5


  • Lifetime Qt Champion

    You'd have to be more specific. Qt 5 is a series.



  • My App is running on version 5.6


  • Lifetime Qt Champion

    Then you might want to run a more recent version of macdeployqt.



  • How do I run a more recent version of macdeployment. I can't seem to find a way to update my macdeplyqt.


  • Lifetime Qt Champion

    You use the macdeployqt from a more recent Qt installation.



  • Edit:

    Thanks it works now.

    I installed Qt version 5.8 and used this guide to sign it: https://successfulsoftware.net/2014/10/17/signing-qt-applications-for-mac-os-x-10-9-5-and-10-10/

    I might need to purchase DropDMG in 30 days, but it'll work for now :)

    Thanks for the help


Log in to reply