Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Error: execvp: ../Widget/mainwindow.ui: Permission denied



  • I work with cross-compiled application in ubuntu 16.04 for a freescale imx6, in the moment of run the application show me this error:

    12:47:34: Running steps for project Widget...
    12:47:34: Starting: "/opt/poky/2.0.3/sysroots/x86_64-pokysdk-linux/usr/bin/qmake2" /home/qt/Widget/Widget.pro -r -spec linux-gnueabi-oe-g++ CONFIG+=debug CONFIG+=force_debug_info CONFIG+=separate_debug_info
    sh: 1: -d: not found
    12:47:34: The process "/opt/poky/2.0.3/sysroots/x86_64-pokysdk-linux/usr/bin/qmake2" exited normally.
    12:47:34: Starting: "/usr/bin/make"
    ../Widget/mainwindow.ui -o ui_mainwindow.h
    make: execvp: ../Widget/mainwindow.ui: Permiso denegado
    make: *** [ui_mainwindow.h] Error 127
    Makefile:201: fallo en las instrucciones para el objetivo 'ui_mainwindow.h'
    12:47:34: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project Widget (kit: ARM imx6)
    When executing step "Make"
    12:47:34: Elapsed time: 00:00.
    .

    Debugger: /opt/poky/2.0.3/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-gdb

    Compiler GCC: /opt/poky/2.0.3/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-g++

    Compiler G++: /opt/poky/2.0.3/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-gcc

    Qt version: /opt/poky/2.0.3/sysroots/x86_64-pokysdk-linux/usr/bin/qmake

    Sysroot: /opt/poky/2.0.3/sysroots/cortexa9hf-vfp-neon-poky-linux-gnueabi

    Hope you help me please, thanks.

    Best regards.


  • Lifetime Qt Champion

    Hi,

    There's something fishy, you have -d not found error, where does it come from ?
    The other error seems to be that the system tries to execute main window.ui rather than run uic on it.



  • @SGaist , The error can't be programming, because only use a button, but in my main.cpp in the #include <QAplication> show me the QApplication no such file or directory and tha tab General Message display following text Failed to set up kit for Qbs: Could not determine whether Qt is a static build..

    My cross-compile application is based in this link: https://community.nxp.com/docs/DOC-94849


  • Lifetime Qt Champion

    What project manager are you using for your project ?

    If qmake, then you are likely missing QT += widgets in your .pro file hence your error about QApplication.

    Your link is only available to registered users.



  • Already add Qt += widgets and reboot Qtcreator in my .pro, but display the same error, the access is XXX and XXX.

    [edit: removed credentials SGaist]


  • Lifetime Qt Champion

    The name of the variable is QT.

    Did you re-run qmake before re-building ?



  • @SGaist , Is correct the variable, sorry, i have tried before create a qmake, but i had a problem with that and have the files, you think you should delete the files??


  • Lifetime Qt Champion

    @Alexander-9 What files do you mean? After changing pro file you need to run qmake again and then rebuild.
    Can you show the content of your pro file?



  • @jsulm I have been working with cross-compile application this way:

    ./configure -opengl es2 -prefix /usr/local/qt5 -extprefix opt/qt5 -device linux-imx6-g++ -device-option CROSS_COMPILE=/opt/poky/2.0/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi- -sysroot /opt/poky/2.0/sysroots/armv7a-vfp-neon-poky-linux-gnueabi -nomake examples -nomake tests -v

    But it shows me this error, do you know solve this, thanks: Screenshot

    Regards.


  • Lifetime Qt Champion

    Looks like your sysroot doesn't contain the needed OpenGL development stuff.

    On a side note: don't build/develop as root you can brick your system without knowing.



  • @SGaist , @jsulm This are steps to get the toolchain:

    • Inside of poky: source oe-init-build-env build.
    • Configure local.conf for the type of machine, in this case is imx6solosabreauto.
    • After of download the toolchain, run ./poky-glibc-x86_64-meta-toolchain-qt-cortexa9hf-vfp-neon-toolchain-qt-2.0.3.sh.
    • Later the url when is the toolchain is the following: /opt/poky/2.0.3/sysroots/x86_64-pokysdk-linux/usr/bin/qmake2.

    I need do other steps more, hope you help me, thanks.

    Regards.


Log in to reply