Important: Please read the Qt Code of Conduct -

Build Qt modules

  • Hello, i compile Qt 5.8.0 with Mingw-64bit with this command

    ..\qt-everywhere-opensource-src-5.8.0\configure.bat -prefix D:\tools\Qt\5.8.0 -opensource -confirm-license -developer-build -debug-and-release -shared -skip qtsensors -skip qtlocation -skip qtconnectivity -skip qtandroidextras -skip qtx11extras -skip qtmacextras -skip qtwayland -skip qtquickcontrols -skip qtquickcontrols2 -skip qtactiveqt -skip qtwebengine -skip qtwebchannel -nomake examples -nomake tests -plugin-sql-odbc -opengl desktop -no-warnings-are-errors

    I try build simple program and that it is ok.

    I will compile additional modules as qtscript, qtcharts, ... I try something like

    ..\qt-everywhere-opensource-src-5.8.0\configure.bat -prefix D:\tools\Qt\5.8.0 -opensource -confirm-license -developer-build -debug-and-release -shared -qtscript -warnings-are-errors

    but unsuccessfully

    This is the Qt for Windows Open Source Edition.
    You have already accepted the terms of the license.
    Creating qmake...
    mingw32-make: Nothing to be done for 'first'.
    ERROR: Unknown command line option '-qtscript'.
    Qmake failed, return code 3

    What is correct way?

    Thank you mk

  • Lifetime Qt Champion


    When calling configure again, you need to do it from a clean state.

    In this case you also have a wrong option. There's such option as -qtscript.

    The most simple to do here is to compile the module directly.

    mkdir qtscript
    cd qtscript
    /path/to/your/qmake ../Qt-sources/qtscript
    make -jX or jom.exe

  • Thank you, problem solved.

Log in to reply