Plugins won't load



  • I just installed Qt on the latest Linux Mint. I was using the Welcome screen as a guide. Now it won't load. When I start Creator, I get a dialog that says Qml Designer, Qml Profiler and Welcome have errors and cannot be loaded. The specific error message is, "Plugin initialization failed: Cannot create OpenGL context."

    I have tried both the Qt version available in the Mint repository and the direct download from Qt. Both do the same thing.

    It's been a long time since I used Linux or tried to program in C++/Qt. I'd really like everything to work.

    Any help in resolving this is appreciated.

    CEJ


  • Lifetime Qt Champion

    Hi,

    Looks like you have an OpenGL issue. What kind of graphics card do you have on your machine ? What drivers are you using ?



  • I'm using NVidea GForce 1070. I have the proprietary drivers installed. I just did a clean rebuild of the entire system today. I get everything but the examples now. The Tutorials are listed, but the Examples page is blank.



  • I just solved my own problem. After doing some searching, I discovered a whole slew of packages with the word "examples" in the name that the Mint package manager did not install along with the supposedly "complete" SDK. There were so many that I didn't know which one(s) I might need. So I uninstalled everything from the Mint repository concerning Qt and installed directly from the Qt site. It was a much larger install package. Now the examples are there and I should, hopefully, be able to continue.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.