QMediaPlayer (dsengine.dll) problem.



  • Hello everyone!

    I hope someone can help me. I've got problem with a new version of Qt (5.8) in QMediaPlayer work. I run RTSP via IP-Camera. In case when I run application through Qt Creator (debug or release - nevermind) and start my QMediaPlayer realisation, it starts OK without issues. But if I build my project, install it on other machine (dynamic link) - video not starts.

    Error log said: The QMediaPlayer object does not have a valid service or QMediaPlayer::ServiceMissingError wich means the same.

    I build on Windows platform and start application on Windows 7 and higher with LAV Filters 0.69 on it.

    Actually, before Qt 5.8, I built on 5.7 and earlier and it works fine. Problem causes dsengine.dll. If I change it to library from 5.7 version or earlier - application runs RTSP correctly.

    So, can anybody offer any solution? Just use older versions of library?

    Some code of player realisation class:

    RtspPlayer::RtspPlayer(QVideoWidget *out, const QString &host, int port, const QString &path,
                           const QString &login, const QString &password, QObject *parent) : Transport(parent)
    {
        _player = new QMediaPlayer;
        QUrl url(QString("rtsp://%1:%2@%3:%4%5").arg(login, password, host, QString::number(port), path));
        connect(_player, SIGNAL(error(QMediaPlayer::Error)), this, SLOT(catchErr(QMediaPlayer::Error)));
        connect(_player, &QMediaPlayer::mediaStatusChanged, this, &RtspPlayer::restartVideo);
        _player->setVideoOutput(out);
        _player->setMedia(url);
    }
    
    bool RtspPlayer::start()
    {
        _player->play();
        emit success();
        return true;
    }
    

    Thanks for advance!


  • Lifetime Qt Champion

    Hi,

    Did you check the bug report system ?



  • Cheked. Not found anything about 5.8. Created own bug: https://bugreports.qt.io/browse/QTBUG-59589


  • Lifetime Qt Champion

    Thanks !



  • Problem solved. It was bug in Inno setup, which corruped Qt5Multimedia.dll somehow.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.