Important: Please read the Qt Code of Conduct -

Unable to execute the player example after a fresh install

  • Dear all,
    I've created a virtual machine with a fresh install of Ubuntu 14.04.5 LTS (Trusty Tahr), then I've installed Qt 5.8. My arch is x64.

    When I try to execute the /home/user/Qt/Examples/Qt-5.8/multimediawidgets/player example (simple audio/video player) I've got the following error:

    defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"

    I've launched the application with the variable QT_DEBUG_PLUGINS=1 and seen that:

    Got keys from plugin meta data ("gstreamermediaplayer")
    QFactoryLoader::QFactoryLoader() checking directory path "/home/user/QtWorkspace/bin/mediaservice" ...
    Cannot load library /home/user/Qt/5.8/gcc_64/plugins/mediaservice/ (/home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ undefined symbol: _gst_value_list_type)
    QLibraryPrivate::loadPlugin failed on "/home/user/Qt/5.8/gcc_64/plugins/mediaservice/" : "Cannot load library /home/user/Qt/5.8/gcc_64/plugins/mediaservice/ (/home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ undefined symbol: _gst_value_list_type)"
    defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"

    What is the cause of the " undefined symbol: _gst_value_list_type" error? Why this mismatch?

    Is it possible that am I missing some GStreamer libraries?

    Ubuntu 14.04.5 LTS (Trusty Tahr) comes with GStreamer 1.0 installed (1.2.4). Is it possible that QtMultimedia does not support it?

    Do I need to install GStreamer 0.1?

    How can I fix this problem and run the player example?

    Thanks in advance for your time

    Best regards,

  • Qt Champions 2019

    @Grynium Yes, you're most probably missing GStreamer libraries.
    You can execute


    to find out what is missing.

  • It seems that all dependencies are satisfied:

    user@user-VirtualBox:~/Qt/5.8/gcc_64/lib$ ldd /home/user/Qt/5.8/gcc_64/plugins/mediaservice/ =>  (0x00007fffe09d1000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49fb0fd000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49faede000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49fabd4000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49fa3a3000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49f9c07000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49f9881000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49f9161000) => /usr/lib/x86_64-linux-gnu/mesa/ (0x00007f49f8ee0000) => /lib/x86_64-linux-gnu/ (0x00007f49f8cc1000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f8a77000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f8831000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f860a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f83fd000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f81a5000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f7ea0000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f7c4f000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f7a4a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f7800000) => /lib/x86_64-linux-gnu/ (0x00007f49f74f8000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f71f4000) => /lib/x86_64-linux-gnu/ (0x00007f49f6eed000) => /lib/x86_64-linux-gnu/ (0x00007f49f6cd7000) => /lib/x86_64-linux-gnu/ (0x00007f49f6912000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f6621000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49f63ca000) => /lib/x86_64-linux-gnu/ (0x00007f49f61b0000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49f5d17000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49f595e000) => /home/user/Qt/5.8/gcc_64/plugins/mediaservice/../../lib/ (0x00007f49f3f7b000) => /lib/x86_64-linux-gnu/ (0x00007f49f3d77000) => /lib/x86_64-linux-gnu/ (0x00007f49f3b6e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f396c000)
    	/lib64/ (0x000055daf79ac000) => /lib/x86_64-linux-gnu/ (0x00007f49f3742000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f353e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f333b000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f3135000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f2f32000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f2d04000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f2af2000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f28ee000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f26e8000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f24e6000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f21b0000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f1f99000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f1d94000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f1b74000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f196e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f1760000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f1527000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f12a5000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f10a0000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f0e98000) => /usr/lib/x86_64-linux-gnu/pulseaudio/ (0x00007f49f0c30000) => /lib/x86_64-linux-gnu/ (0x00007f49f0a25000) => /lib/x86_64-linux-gnu/ (0x00007f49f07e0000) => /lib/x86_64-linux-gnu/ (0x00007f49f05a1000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f039c000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49f0196000) => /lib/x86_64-linux-gnu/ (0x00007f49eff8b000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49efd23000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49efb1d000) => /lib/x86_64-linux-gnu/ (0x00007f49ef902000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49ef6d1000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49ef202000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49eefd4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f49eedcb000) => /lib/x86_64-linux-gnu/ (0x00007f49eebb0000)

  • Lifetime Qt Champion


    I wonder if you are hitting that bug.

  • Exactly the same problem!
    same os, same qt version, and the same error !

  • @Grynium did u solve the problem?

  • @rickywong2017 the same to me ,did u solve this problem?

  • @ed_u the sad thing is not, i've changed the qt version to Qt5.6.2 and this error simply just dont happen.

  • Solution for Qt 5.8.0 on Ubuntu 14.04

    This is basically the error:

    Cannot load library /home/massimo/projects/Qt5.8.0/5.8/gcc_64/plugins/mediaservice/ (/home/massimo/projects/Qt5.8.0/5.8/gcc_64/plugins/mediaservice/../../lib/ undefined symbol: _gst_value_list_type)

    Which means the Qt Multimedia team didn't consider the gstreamer version shipping on Ubuntu 14.04 which is 1.2.3.
    To solve you need to update GST with a PPA. Seems 1.6.x is enough to make Qt happy.

    sudo add-apt-repository ppa:dan-witt/gstreamer
    sudo apt-get update
    sudo apt-get upgrade

    Footnote: 14.04 is a LTS version and Qt didn't care. This is horrible and bad decision making IMHO.

  • Lifetime Qt Champion

    @mcallegari79 If you want LTS everywhere then Qt 5.6 is the current LTS not 5.8.

  • @rickywong2017 Why i still got that error when running the example on 5.6.2 :((
    I am newbie. Sorry if my question is noob.
    Can anyone tell me how to launched the application with the variable QT_DEBUG_PLUGINS=1

  • Qt Champions 2019

    @tamolo In the command line:

    $ ./my_app

    Or in QtCreator set this variable in "Projects/Run/Run Environment/Add".

  • thank you so much

  • @Grynium @rickywong2017
    This is the way i fixed it.
    Step 1: use 'apt-cache search -n gstreamer' to get the list all of the gstreamer and libgstream lib
    Step 2: for each of lib in the list. Use 'apt-get install name-of-the-gstreamer-lib' to install it. After install almost the lib in the list my example run. ( i don't know which is the exactly lib i need to install. I just install all of them until my example run)
    Step 3: rebuild your example and run.

    I hope this help.

Log in to reply