[SOLVED] Video streaming



  • Hi

    I've made a small app, which uses QMediaPlayer and QVideoWidget (qtmobility).
    The app should have a predefined list of rtsp streams, and play the selected one.

    App works ok on N900 device, network connection is established, stream is playing.
    But on symbian phones (N95, E71, C6 00), network connection is successfully established, the stream does not start at all.

    Any idea what should I do to make it work? Could there be something with symbian capabilities settings in myapp.pro file?

    Currently I set the following capabilities in .pro file:

    @
    TARGET.CAPABILITY += NetworkServices
    ReadUserData
    WriteUserData
    UserEnvironment
    ReadDeviceData
    WriteDeviceData
    SwEvent
    @

    App is signed with symbian open signed online.

    [EDIT: code formatting, please wrap in @-tags, Volker]



  • anybody?



  • Sorry, haven't tried QVideoWidget yet. If no one can help here I'd make a stripped down example and file a bug report (remember to attach the example code)



  • The QVideoWidget is by default using the streaming access point specified in the internet connectivity settings of the phone. There doesn't seem to be a way to influence this choice yet. So - if the same code works on the N900 and doesn't on Symbian, I would suggest testing the URL with the native video player if possible to see if the phone is correctly set up for playing videos.

    Capabilities should be fine - you don't actually need most of them (e.g., SwEvent shouldn't be necessary). NetworkServices is the main one so that the app can access the internet. Then, self-signed is ok already.



  • Thanks for all the responses.

    It works now also on symbian.
    Capabilities were ok as ajaki suggested.
    The problem was in gsm/umts network. I was on gsm, and it seems that
    N95 needed umts for streaming that particular content.



  • Hi,

    I'm making a port of a steaming Media player app. The application works on meego, but I have similar issues on N8. Networking seems to be working ok, but when I try play/stream a video using QMediaPlayer "Connection failed Access Denied" notification appears for a short while on the target device

    Any suggestions, anyone?

    Thanks!



  • Hi,
    very nice thread :)



  • It is also worth noting on S^3 devices that the IAP for video streaming can be set independently by going to Settings->ApplicationSettings->Videos->Access Point In Use. This may be helpful if you're trying to use a QML Video Element (which attempts to use the IAP specified in that option, I believe, and not the default access point for data specified elsewhere in phone settings).

    I believe that this setting may be modified programmatically using the QtMobility APIs, but I can't personally confirm that.

    Cheers,
    Chris.



  • Thank you for the information! Will check that.

    BTW, newer version of Qt Mobility, 1.2beta also helps some of the aspects of this issue.

    Cheers,
    Max



  • I still have issue with the video output on 700. Streaming seems to be ok, audio is ok, but can not make the frames appear in the video output.

    (I also made the most simple app, http://doc.qt.nokia.com/qtmobility-1.2/qmediaplayer.html#details, work on my device, but that doesn't show the frames either)

    Anybody? any suggestions?

    Thanks,
    Max


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.