cross compiler Qt5.5 to freescale imx6



  • before cross compile to make, I first configure all items I need found one item “EGLFS i.MX6....... . no”, I don't know how to enable it.
    as I run one application dashboard that need OpenGL library on develop board(freescale iMx6), and then the output error message as following.
    Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile 0) Aborted;
    configuration as below:
    OpenGL / OpenVG:
    EGL .................. yes
    OpenGL ............... yes (OpenGL ES 2.0+)
    OpenVG ............... yes-auto
    PCRE ................... yes (bundled copy)
    pkg-config ............. yes
    PulseAudio ............. no
    QPA backends:
    DirectFB ............. no
    EGLFS ................ yes
    EGLFS i.MX6....... . no
    EGLFS KMS .......... no
    EGLFS Mali ......... no
    EGLFS Raspberry Pi . no
    EGLFS X11 .......... no
    LinuxFB .............. yes
    XCB .................. no
    Session management ..... yes


  • Moderators

    @Dylan-NO1 You can always run configure with -v option, then you will see more.
    To enable EGLFS you need to install related headers/libs for it. How to do so depends on the operating system which is running on your target device or on the provider of your sysroot.



  • @jsulm Hello thanks for your support, I will try it again follow you comments, and do you know what is the reason of error message"Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior 2, swapInterval 1, profile 0) Aborted" as I run one application dashboard that need OpenGL module I already installed.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.