Cannot deploy to iOS simulator



  • I have Qt 5.8 on OS X 10.11.6 and want to run apps on an Android device and on iOS simulator. Testing with default files produced by File / New project it works fine with a connected Samsung S7, but with iphonesimulator-clang I get "Application install on Simulator failed. Simulator not running.", although the simulator (iphone 6S) really IS running. What is wrong? What can I do?


  • Lifetime Qt Champion

    Hi,

    What version of Qt are you using ? What about xCode ?



  • Qt 5.8. Xcode 7.3.1.
    Turned out to work (at least for the moment) after restarting QtCreator. What still doesn't work is console.log (said to require Xcode 8; I hesitate updating).
    How can I simulate device ipad 2 instead of iphone 6S, which seems to be the default? If I choose ipad 2 in Simulator/Hardware/Device my application disappears. If I do QtCreator/Run again a new instance of iphone 6S is started.


  • Lifetime Qt Champion

    Do you have specific reason for not updating ?

    Do you have any iOS specific settings in your .pro file ?



  • I don't expect much benefit from Xcode 8 and some people have problems. I'll wait with the update until we all who work together do.
    I have no iOS specific settings in the .pro file; "using default rules for deployment".



  • @SGaist One way to see console output could be to open the system log. Tried, but I can't find it there either. Any hints?
    Any way to simulate iPad 2 instead of iPhone 6S?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.