libQt5Core.so.5: version `Qt_5' not found



  • Hi, all!

    My colleague compiled an application. It works on his PC with Linux.
    When I'm trying to run the same executable on my Ubuntu, it throws me errors:

    ./application: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: version `Qt_5' not found (required by ./application)
    ./application: /usr/lib/x86_64-linux-gnu/libQt5Multimedia.so.5: version `Qt_5' not found (required by ./application)
    ./application: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: version `Qt_5' not found (required by ./application)
    ./application: /usr/lib/x86_64-linux-gnu/libQt5SerialPort.so.5: version `Qt_5' not found (required by ./application)
    ./application: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version `Qt_5' not found (required by ./application)
    ./application: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by ./application)
    ./application: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by ./application)
    

    However, all mentioned libraries are in the required folder. For example

    vitya@dev-machine:~/$ ls -la /usr/lib/x86_64-linux-gnu/libQt5C*
    lrwxrwxrwx 1 root root      19 вер 19 18:37 /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 -> libQt5Core.so.5.5.1
    lrwxrwxrwx 1 root root      19 вер 19 18:37 /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.5 -> libQt5Core.so.5.5.1
    -rw-r--r-- 1 root root 5052920 вер 19 18:38 /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.5.1
    

    How can I run an app?



  • Hi, you have Qt 5.5.1 installed in your Ubuntu but your colleague built his application using Qt 5.6 or later, so the needed .dlls/.so files for his Qt app are missing :-( Perhaps your colleague can give them to you...



  • Hi, @hskoglund!
    How did you understand from the output that my colleague has Qt 5.6 or later?



  • @lvitya said in libQt5Core.so.5: version `Qt_5' not found:

    Hi, @hskoglund!
    How did you understand from the output that my colleague has Qt 5.6 or later?

    ./application: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by ./application)

    The error on your first post tell :
    version `Qt_5.7' not found



  • @mostefa However lines for other libraries don't say anything about "Qt_5.7" version. And @hskoglund was telling about Qt 5.6.


  • Qt Champions 2016

    @lvitya said in libQt5Core.so.5: version `Qt_5' not found:

    However lines for other libraries don't say anything about "Qt_5.7" version.

    This is of no consequence as everything depends on QtCore anyway.

    And @hskoglund was telling about Qt 5.6.

    Because you'd have the same problem if the application was built against Qt 5.6.
    You either need to upgrade your Qt to version 5.7 or your colleague has to build and link the application against Qt 5.5.



  • @kshegunov

    This is of no consequence as everything depends on QtCore anyway.

    Nice point, didn't guess about it.

    You either need to upgrade your Qt to version 5.7 or your colleague has to build and link the application against Qt 5.5.

    I have only Qt Creator. Probably colleague has to build and link statically.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.