qtcreator-4.2.1 failed to launch on centos 6.8



  • Hello I've just installed qtcreator-4.2.1 on centos 6.8

    it failed to launch

    ./qtcreator: /lib64/libc.so.6: version GLIBC_2.14' not found (required by ./qtcreator) ./qtcreator: /lib64/libc.so.6: versionGLIBC_2.14' not found (required by /home/centos/qtcreator-4.2.1/bin/../lib/qtcreator/libExtensionSystem.so.4)
    ./qtcreator: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /home/centos/qtcreator-4.2.1/bin/../lib/qtcreator/libAggregation.so.4) ./qtcreator: /lib64/libc.so.6: versionGLIBC_2.14' not found (required by /home/centos/qtcreator-4.2.1/bin/../lib/qtcreator/libUtils.so.4)
    ./qtcreator: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /home/centos/qtcreator-4.2.1/bin/../lib/Qt/lib/libQt5Widgets.so.5) ./qtcreator: /lib64/libc.so.6: versionGLIBC_2.14' not found (required by /home/centos/qtcreator-4.2.1/bin/../lib/Qt/lib/libQt5Gui.so.5)
    ./qtcreator: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /home/centos/qtcreator-4.2.1/bin/../lib/Qt/lib/libQt5Concurrent.so.5) ./qtcreator: /lib64/libc.so.6: versionGLIBC_2.14' not found (required by /home/centos/qtcreator-4.2.1/bin/../lib/Qt/lib/libQt5Network.so.5)
    ./qtcreator: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /home/centos/qtcreator-4.2.1/bin/../lib/Qt/lib/libQt5Core.so.5) ./qtcreator: /lib64/libc.so.6: versionGLIBC_2.14' not found (required by /home/centos/qtcreator-4.2.1/bin/../lib/qtcreator/../Qt/lib/libQt5Qml.so.5)

    the 4.2.0 can work perfectly on centos 6.8

    please fix it, many thanks!


  • Moderators

    @12398890

    Do you have the correct version of GLIBC installed?
    It is specifically asking for version GLIBC_2.14. I am not expert on linux, but as far as I remember you install different versions for different libs.
    In case this is really a bug and needs a fix, this is definitely the wrong place to post a bug report. The forum posts will not be monitored for eventual bug reports. The right place for a bug report would be JIRA.


  • Moderators

    @12398890 I don't think CentOS 6.8 will ever become a newer GLibC version - this library is one of the core libs which usually are not updated in the lifecycle of a Linux distribution (only bug fixes). Can't you updgrade to a newer CentOS version?
    An alternative would be to try to build QtCreator by yourself.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.