Trouble with compilator after modify a flag



  • today a i finished upmy project but to work outside the QT creator i had to fill a folder with dll's and put the exe inside to make it working
    but i wanted something better so i searched up like everything to compress the exe and the dll together i finished creating qrc files willed with dll's i thinked up that was a good idea then i compiled it and an error appeared i knowed that the error was relacionated with the size of the qrc and i start dividing them at the end frusted by the same error everytime i decided google the problem online then i found a guide and i followed this steps
    "If your OS is 32bit, then in cmd (as Admin) put bcdedit /set IncreaseUserVa 3072
    Install masm32;
    open cmd (as admin too);
    put cd C:\Qt\Tools\mingw492_32\libexec\gcc\i686-w64-mingw32\4.9.2
    put C:\masm32\bin\editbin.exe /LARGEADDRESSAWARE cc1plus.exe"

    also now compiles but the program wont start this is a screen of what happen alt text

    i have really no idea if what to do now i don't know how to reverse the procedure also i still haven't found a way to compress all together
    also i'm using the minGW32bits3 compiler i hope you that are watching this thread right now can help me
    1 finding a compressor that compress all the dll and folders into one exe
    2 resolving the compilator problem

    if you can't well thank you anyway for try it


  • Moderators

    @Massimiliano Please read http://doc.qt.io/qt-5/windows-deployment.html
    Use the windows deployment tool to deploy your app, then you can compress the directory you get using this tool. This directory will contain your executable and all needed DLLs.
    Putting DLLs in a resource file is something I never seen so far. And it cannot work because the DLLs must be there while your app is being loaded by the OS - at that time it is not yet running.



  • @jsulm well the flag thing i solved it but when i try the windows deploy thing (to what i undestand i have tu drag and drop it in the program floder with all the dll's then run it) i give me that erroralt text


  • Moderators

    @Massimiliano No, you do not drop it in your app directory! You just need to call it in a terminal window and pass the path to your binary as parameter. Please read the documentation:
    "The tool can be found in QTDIR/bin/windeployqt. It takes an .exe file or a directory that contains an .exe file as an argument, and scans the executable for dependencies."


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.