Cross compilation problem with QtCreator [Yocto Image]



  • Hello Everyone,

    I've bitbaked a qt5 image for my Beaglebone Black and exported the cross-toolchain sdk.
    I also tried to setup QtCreator to work with the output toolchain with the steps in this link

    I put this code at the beginning of the qtcreator.sh file to change the environment variables

    source /opt/poky/1.6.1/environment-setup-cortexa9hf-vfp-neon-poky-linux-gnueabi 
    

    and configured the following options

    • qmake : /home/user/cross/sysroots/x86_64-pokysdk-linux/usr/bin/qt5/qmake

    • g++ compiler: /home/user/cross/sysroots/x86_64-pokysdk-linux/usr/bin/arm-poky-linux-gnueabi/arm-poky-linux-gnueabi-g++

    • Sysroot: /home/user/cross/sysroots/cortexa8hf-neon-poky-linux-gnueabi

    However, when I build the project I get the following errors :

    error: cannot find -lQt5Widgets
    error: cannot find -lQt5Core
    error: cannot find -lQt5Gui
    error: collect2: error: ld returned 1 exit status
    

    Does anybody have a solution for this?

    P.S. when I compile the project using terminal it compiles with no error and works well on the target. My host machine is running on Ubuntu 16.0.



  • In your kit where you have toolchain, and qt for bbb generated by yocto set Qt mkspec to

    linux-oe-g++
    


  • @tomasz3dk Thank you very much, that worked fine.



  • @tomasz3dk, Hi the carpet linux-oe-g++ where i can find??, because i have the same problem, only i installed qt creator 4.2.2.

    I hope you can help me. thanks.

    Regards.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.