Maemo N900 hangs after component update



  • Hi to all,

    I have a problem on N900 maemo 5 occoured during a process of update that in about one hour seems to be degenerated to something unclear and chaotic.

    Starting from a Qt quick application that runs on Symbian^3 where the UI has been developed in QML I tried to setup the N900 to run the application.

    Working with a Mac running Snow Leopard 10.6 as development platform I connected to it the N900 device. The maemo is correctly updated to the last version and all seems good. During the new device registration in Qt Creator trying to use the SSH method with key exchange between the desktop and the arm device I experienced always the same problem: during the key deploy to the device I receive the message that the string B... is too long and the key deployment hangs sistematically. Thus I launched Mad (last version from the repo) leaving the program open with the temporary password and I have used the Pasword method on Qt Creator instead of the key method. The device is recognized (usb connection) and all seems working fine.

    At this point I buid the application and try to deliver it to the N900 device. I see a problem due to the mobility libraries that need to be updated on the device. This is normal because the app uses mobility to access ovimaps. Following the documentation I try to install the library from the terminal on the N900 with the following command:

    @/usr/lib/mad-developer/devrootsh apt-get install libqtm-*@

    Installation go ahead for a while then stops signaling that there are problems downloading a component. Ask to run apt-get update before because there is some repository not completely updated.
    Running apt-get update the command stops with the message that there is no more disk space. I always check before any installation or system update to be sure that there is sufficient disk space in the area for installation (the main folder, the user libraries etc.) so this message sounds very strange.

    I think that the problem can be some trashable download forget in some tmp folder during the first update so I reset the device.

    After the reset (power-off then power-on) the disk-usage app shows a lot of free space, but the command reports again the same error. Using the grapic utility on the N900 to see disk-usage, the program reports a no partitions found message.
    When I try to connect the device with the usb in Storage mode I see both the internal memory and the external memory with a lot of space free. But I never see the partitions running diskusage or trying to work on the N900 terminal.

    Note that all the other things of the device works fine i.e. phone calls, contacts, sms, images, and all the other applications.

    Last test is on the graphic interface to manage installed programs and repositories on the device reporting that there are no programs installed and no repositories anywhere.

    I have not great ideas at this point. I don't like it too much, but if there are no other ways I can also reset the N900 to the initial conditions, but what is the method ?

    Thank to all in advance for any suggestion.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.