Qmake cannot execute with faulty kit?



  • My code is using QWidget to produce a display window with balls bouncing in a box; regardless, the code cannot compile on my home computer (works fine on the uni computers). When I build I am returned with these errors:
    19:40:51: Configuration unchanged, skipping qmake step.
    19:40:51: Could not start process "mingw32-make.exe"
    Error while building/deploying project BouncingBalls (kit: Desktop Qt 5.7.1 MSVC2015_64bit)
    The kit Desktop Qt 5.7.1 MSVC2015_64bit has configuration issues which might be the root cause for this problem.
    When executing step "Make"
    19:40:51: Elapsed time: 00:00.

    Checking on the Tools->Build&Run->Qt Versions, it returns "No compiler can produce code for this Qt Version. Please define one or more compilers."
    Which compiler is recommended to download to resolve this, or should I revert to an earlier version of Qt?


  • Moderators

    @DominicB

    Hi and welcome to devnet forum

    Since you have apparently downloaded Qt version for MSVC2015 you would need to install also that particular compiler on your machine.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.