Project not generating executable



  • Hello,

    I have a project with several libraries and executables that work fine under windows.

    However, when I try to use it under Linux (Fedora) only the libraries are built. Is there a Linux specific configuration to build the executable when I build the global project?

    I can manually build the subproject containing the executable.

    Furthermore, the executable built are not detected by Qtcreator => I cant use the run/debug



  • Are you using qmake for this? If so, please show us your project file.



  • Ok, im stupid. Two days I have this issue, I ask here, and in the next 10 minutes I find a hidden

    win32{
    }

    that was causing my problem.

    Sorry for the trouble

    (But I dont find how to mark my problem solved)



  • Hehe, I know how that feels. Good that you could solve it :-)


  • Lifetime Qt Champion

    Hi,

    Use the "Topic Tools" button and first click on Ask as a question then click the button again and you can mark it as solved.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.