QtWebView : Multi-platform sound playback and display issues



  • Hello,

    I'm currently testing Qt as one of the possible candidate frameworks in which to develop a multi-platform application. My requirements are:

    a) The application must run on : Windows (Desktop), MacOSX, Linux (Desktop), Android, iOS;
    b) The application must (among other things) correctly handle web content which I do not control;
    c) Since multimedia is a big thing nowadays, correctly handling audio & video is a big requirement for my app;

    Judging from Qt's pretty screenshots and docs, it seemed that the QtWebView component might be just the thing I need for my application.

    However, let's abandon marketing materials and briefly delve into reality.

    Note: in the context of this post, "video" means Youtube video.

    QtCreator 4.1.0 -> Examples -> minibrowser built for and deployed on:

    Windows (10)

    • Video sound : Working;
    • Full screen video player option : Not working (clicking on the the video player's "Full screen" option accomplishes nothing);
    • Theater Mode video player option : Working, but breaks video player layout;

    Android device (Android 5.0.2 - Lollipop)

    • Video sound : Working
    • Full screen video player option : Unavailable
    • Theater Mode video player option : Unavailable

    Android simulators - NOT TESTED

    MacOSX (MacOSX 10.11 - El Capitan)

    • Video sound : Working
    • Full screen video player option : Not working (clicking on the the video player's "Full screen" option accomplishes nothing)
    • Theater Mode video player option : Working, but breaks video player layout

    iOS device (iOS 10.1 - iPad Retina)

    • Video sound : Not working
    • Full screen video player option : Working
    • Theater Mode video player option : Unavailable

    iOS device ( iOS 10.1 - iPhone 5s)

    • Video sound : Not working
    • Full screen video player option : Working
    • Theater Mode video player option : Unavailable

    iOS simulator (iOS 10.1 - iPad Retina)

    • Video sound : Working
    • Full screen video player option : Working
    • Theater Mode video player option : Unavailable

    iOS simulator (iOS 10.1 - iPhone 5s)

    • Video sound : Working
    • Full screen video player option : Working
    • Theater Mode video player option : Unavailable

    To sum it up, 2 issues become immediately evident:

    a) Sound playback issues : no video sound on 2 different iOS devices (whereas the equivalent iOS simulators, Windows, MacOSX and Android do not replicate this issue);
    b) Display issues;

    Ignoring the display issues (b), does anyone have any ideas vis. the sound playback issues (a) ? The physical devices experience no sound playback issues whatsoever in other applications. It is puzzling that the iOS simulators play sound just fine while the physical devices don't when attempting to watch videos via the minibrowser app.

    Thank you.



  • Windows (10) behaviour confirmed on Windows 7, Qt 5.7, MSVC2013

    You probably should post this in bugreports.qt.io



  • @VRonin

    Thank you for the suggestion.

    The Windows 10 behavior (meaning display issues) it's the same on MacOSX. On Windows 10 I'm building with MSVC2015_64bit. On MacOSX with clang 64 bit.

    However, the sound playback issues in iOS devices are far more annoying for me at this point.



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.