Qt 5.7 online installer macOS Sierra 10.12.1 path



  • Hello, this is my first installing Qt SDK on mac. I tried to install in my home directory, but got two problems with path.

    The first one was that i have directory with non-ascii(cyrillic) name, and until i didn't renamed it, qmake couldn't find .pro file.

    The second problem is more hard to resolve. The path to Qt is "/Volumes/Macintosh HD/Users/distress/Qt/5.7". As you can see, it have one whitespace. So, when i tried to build test project i got message: "no such file or directory: 'HD/Users/distress/Qt/5.7/clang_64/lib'". I found that Makefile has incorrect LIBS path:
    "LIBS = $(SUBLIBS) -F/Volumes/Macintosh\ HD/Users/distress/Qt/5.7/clang_64/lib -framework QtCore "
    it has two backslashes, it's strange because all other paths have correct one backslash escape for whitespace.

    May be somebody had already successfully resolve such problems?

    Sincerely, George.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Not necessarily the answer you are looking for but I usually use System as the name for the main macOS partition which avoids that problem.



  • @SGaist that's not main partition) (the main is small SSD).
    Ofcouse i can create symlink, or mount to path like /usr/local/lib/qt and reinstall, but may be someone have more universal and elegant solution.
    In any case, I believe that it is incorrect behavior of Qt, because i use their installer with all default options.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.