Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt build error



  • Hi,

    I am installing Qt 5.7 in RHEL6.6. I get the following error while run:
    g++ -c -pipe -g -std=gnu++11 -Wall -W -D_REENTRANT -fPIC -DQT_QML_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I../../../chk/tr1 -I. -I/opt/Qt5.7.0/5.7/gcc_64/include -I/opt/Qt5.7.0/5.7/gcc_64/include/QtWidgets -I/opt/Qt5.7.0/5.7/gcc_64/include/QtGui -I/opt/Qt5.7.0/5.7/gcc_64/include/QtCore -I. -I. -I/opt/Qt5.7.0/5.7/gcc_64/mkspecs/linux-g++ -o main.o ../../../chk/tr1/main.cpp
    cc1plus: error: unrecognized command line option "-std=gnu++11"
    make: *** [main.o] Error 1
    make: Leaving directory `/home/Prerna/Desktop/example/ex2/tr1'
    11:37:33: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project tr1 (kit: Desktop Qt 5.7.0 GCC 64bit)
    When executing step "Make"

    11:37:33: Elapsed time: 00:00.



  • sorry, i have already installed qt 5.7 and when i run a program i get this error



  • can anyone please help me with this error?



  • Hi @prerna ,

    I had just installed qt 5.7 on RHEL6.6 and the installation went perfect,

    Probably u have missed some installation steps...

    nirh



  • i used offline installer and GCC is 4.4 maybe that is the prob i need GCC 4.7 i think



  • could you please mention the steps you followed and from which file did you install? .run/.tar etc
    Also what necessary files should be downloaded for Qt to run without any problems?


  • Lifetime Qt Champion

    Hi,

    Either use a version of Qt that is smaller that 5.7 or upgrade your compiler.



  • Hi,
    Thank you :)I figured out it was not working first because of gcc compiler (the version i had was an old one) i installed gcc4.8.1after that through devtoolset-2 and it worked fine.However there is new error LibGL error unable to load driver nouveau_dri.so
    Can you tell me what is this error?


  • Lifetime Qt Champion

    What OpenGL library do you have installed ?



  • i did not install any. How to do that? which one should i install


  • Lifetime Qt Champion

    Since you're on RedHat: yum install mesa-libGL-devel


Log in to reply