Not able to set the compiler for Qt



  • This is the first time i am using Qt and i am getting an error in setting up the compiler.

    The issue i am sseing is :
    :-1: error: Qt Creator needs a compiler set up to build. Configure a compiler in the kit options.

    The compiler output i am seeing is :
    15:40:30: Configuration is faulty. Check the Issues view for details.
    Error while building/deploying project roshtestqt (kit: Desktop Qt 5.7.0 clang 64bit)
    When executing step "Make"

    I am using a mac laptop. May i know under which folder the compiler is residing. Please help me to resolve this issue.


  • Moderators

    @roshKrish

    Do you have the compiler installed?
    I am not using mac. However, in general one has to install the proper compiler separately. For instance on windows, you have to install the correct MS VS comipler. The version has to match the version used for the precompilation of the Qt build you have installed. Because of license reasons this compiler you have to download and install separately. On windows the Qt maintenance tool does allow you to install also the MinGW compiler directly parallel to Qt libs. However, you still have to choose that you want to install the compiler.

    Therefore, check out if you have the correct compiler installed as used for the prebuild of Qt libs.



  • @koahnig Any idea how to get the compiler for Mac?


  • Moderators

    @roshKrish

    As noted above I have never worked with Mac.

    Make sure match those requirements.

    As it looks the compiler shall be already coming with the OS. Check the OS version you are using. Otherwise you may try with the apple web-page.

    I will see that someone with Mac experience sees this thread. I am of little help here.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You need to install Xcode. You can get it from the Mac App Store directly.

    Note that Xcode 8 has brought in some funky changes, so for now, you might better go with 5.6.2 which already had some fixes to handle that.



  • @SGaist I have already installed Xcode. Qt creator version is

    0_1477645098313_Screen Shot 2016-10-28 at 09.57.18.png

    I am getting this error too

    RORADHAK-M-N29S:bin roradhak$ ./xcodebuild
    xcodebuild: error: The directory /usr/bin does not contain an Xcode project.


  • Lifetime Qt Champion

    Did you install Xcode 8 ?

    Your other error comes from the fact that you are calling xcodebuild in the folder where it's located and not where a Xcode project can be found.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.