Important: Please read the Qt Code of Conduct -

QtCreator doesn't open the CMake Wizard

  • Hi,

    i'm trying to use QtCreator 4.1.0 to open an existing cmake project. When i open a CMakeLists.txt via File -> "Open File or Project..." the CMake Wizard doesn't appear. Instead of the CMake Wizard i get into "Configure Project" asking me to select a kit.

    The CMakeLists.txt is correct and works fine when using cmake directly.

    When i start qtcreator over a terminal i get the following message:
    "The command "/qmake" could not be started."

    Maybe this is the cause of the problem.

    qmake is already installed

    # find /usr -name qmake -type f

    and executable

    # ls -lsa /usr/lib/x86_64-linux-gnu/qt5/bin/qmake
    3004 -rwxr-xr-x 1 root root 3075784 Mai 19  2015 /usr/lib/x86_64-linux-gnu/qt5/bin/qmake

    Maybe some can help me with this issue.


    QtCreator 4.1.0
    Debian Jessie

  • Lifetime Qt Champion

    @by-erik qmake is not needed for CMake projects.
    What happens if you just continue with selecting a Kit?
    As far as I know CMake handling changed in QtCreator recently.

  • Thanks for your reply.

    For a simple HelloWorld cmake project continue with selecting a Kit works fine. But a more complex cmake project ended up in a configuration loop.

    You have changed variables that require your cache to be deleted.
    Configure will be re-run and you may have to reset some variables.
    The following variables have changed:
    CMAKE_CXX_COMPILER= /usr/bin/g++

    In the meantime i found out a workaround.

    I did install QtCreator 3.2.1 and open initially the project with this version. QtCreator 4.1.0 converts the CMakeLists.txt.user file and works fine now.

  • Just another workaround.

    • Tools -> Options...
      • Build & Run -> Kits
        • Select Desktop (default) and press Clone
        • In the cloned one Change 'CMake Configuration' and remove 'CMAKE_CXX_COMPILER:STRING=%{Compiler:Executable}'

    Just for the record. My cmake project makes use of

    SET(CMAKE_CXX_COMPILER /usr/local/angstrom/arm/bin/arm-angstrom-linux-gnueabi-g++)

    It seems that 'CMAKE_CXX_COMPILER:STRING=%{Compiler:Executable}' overwrites CMAKE_CXX_COMPILER from the CMakeLists.txt file.

Log in to reply