Build Qt 5.6.0 for iOS on Mac - what build configuration?



  • Hello,

    I build my iOS application under Xcode using Qt 5.6.0. Now I also want to compile my own (possibly patched) version of Qt 5.6.0 and so I got me the sources from the git repo:

    git clone http://code.qt.io/qt/qt5.git
    perl init-repository --module-subset=default,-qtwebkit,-qtwebkit-examples,-qtwebengine
    git checkout v5.6.0
    

    Next I need to configure/make/make install but I dont know what configure options I have to provide to achieve the same build result as is delivered with Qt 5.6.0 for iOS.

    I tried

    ./configure
    

    without options. But after make and make install there are not the required libs in the install libs directory. I tried

    ./configure -debug-and-release -sdk iphoneos -sdk iphonesimulator -static
    

    but this leads to compile errors.

    What are the right options for configure?

    Thanks,

    Rolf


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Here you can find the configure option you need.

    Note that if you called configure into the sources, you'll have to first clean them before restarting.

    One simpler way to do it is to use out of source builds so that if you want to change something you just nuke the folder and start again.



  • After several problems I upgraded to Xcode 8.0. Now ./configure runs with the options you showed me.

    But at the end of make i get the following:

    === BUILD TARGET qtplugininfo OF PROJECT qtplugininfo WITH CONFIGURATION Release ===
    
    Check dependencies
    No profiles for 'com.yourcompany.qtplugininfo' were found:  Xcode couldn't find a provisioning profile matching 'com.yourcompany.qtplugininfo'.
    Code signing is required for product type 'Application' in SDK 'iOS 10.0'
    

    This seems to be more a "building your stuff for ios devices" than an Qt issue but I didn't get passed that yet.


  • Lifetime Qt Champion

    Xcode 8.0 has brought in some new funkiness. If possible you should migrate to 5.6.2 which should address parts of it.

    Otherwise, open Xcode and check your settings, you may have to sync again your developer account stuff.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.