Qt with QtGStreamer



  • I try to use the QtGStreamer in my qt project but I can't make it work I download the lib from here
    I download the last version 1.2.
    when I go to the example and try to compile VOIP example That come with the downloaded Lib I get this error
    Qt5GStreamer-1.0 development package not found
    so i commented this line in .pro file CONFIG += link_pkgconfig
    and try to add the QGstreamer myself by adding src file to VOIP example file and write this in .pro file #INCLUDEPATH += $$PWD/src
    I found it needs a boost so i add boost lib to it

    #INCLUDEPATH += C:/boost_1_61_0
    #LIBS += "-LC:/boost_1_61_0/stage/lib"

    after that, i got 103 all refer to the m_pipeline each line that contains m_pipeline I get an error all contains undefine refrence to I think the problem in linking the lib and no error in the example for sure and I stuck here i want to comiple it using qmake
    please help me to make this example work
    Thanks in advance


  • Lifetime Qt Champion

    Hi,

    Something's not clear, are you building the whole QtGstreamer sources within your application ?
    `



  • yes, I take the source to the project dir and add this to .pro file #INCLUDEPATH += $$PWD/src
    this folder contains the QGlib - QGst - qml


  • Lifetime Qt Champion

    What about first building these libraries ?



  • i try to follow the steps in readme file and download all dependecies that need to make lib work the Gstream boost lib and all these
    and go to the example folder and try to compile the voip example i got this error that Qt5GStreamer-1.0 development package not found !
    after that i try some soultion to as written in question
    so what i should do to make it work please help me and thanks for your replay


  • Lifetime Qt Champion

    You should do like you did for boost, add the path to where the .lib files can be found.



  • i add those
    INCLUDEPATH += C:/boost_1_61_0/
    LIBS += "-LC:/boost_1_61_0/stage/lib"

    INCLUDEPATH += C:/Users/a7a/Downloads/qt-gstreamer-1.2.0/src

    INCLUDEPATH += C:/gstreamer/1.0/x86_64/lib

    and the same error Qt5GStreamer-1.0 development package not found



  • see i found this line in .pro file

    Tell qmake to use pkg-config to find QtGStreamer.

    CONFIG += link_pkgconfig !? how the qmake can't find the package. it's the QtGstream folder i downloaded how give me this error ?
    Qt5GStreamer-1.0 development package not found !!


  • Lifetime Qt Champion

    Because by default it uses pkg-config which is not installed on Windows.

    You are still not adding the link flags to your .pro file for QtGStreamer.



  • how can i add please tell me i add this
    INCLUDEPATH += C:/Users/a7a/Downloads/qt-gstreamer-1.2.0/src
    the path to QGstream folder that contain the Libs the folder (QGlib - QGst - qml) ? what should i add
    i should remove this line CONFIG += link_pkgconfig ?


  • Lifetime Qt Champion

    See here on how to do it with Qt Creator



  • ok what i do is that
    first i comment these lines

    # Tell qmake to use pkg-config to find QtGStreamer.
    #CONFIG += link_pkgconfig
    
    ## Now tell qmake to link to QtGStreamer and also use its include path and Cflags.
    #contains(QT_VERSION, ^4\\..*) {
    #  PKGCONFIG += QtGStreamer-1.0 QtGStreamerUi-1.0
    #}
    #contains(QT_VERSION, ^5\\..*) {
    #  PKGCONFIG += Qt5GStreamer-1.0 Qt5GStreamerUi-1.0
    #  QT += widgets
    #}
    

    and add these

    INCLUDEPATH += C:/gstreamer/1.0/x86_64/lib C:/Users/a7a/Downloads/qt-gstreamer-1.2.0/src C:/boost_1_61_0/ $$PWD/dependencies/glib_2.28.8-1_win32/bin
    LIBS += "-LC:/boost_1_61_0/stage/lib" -L -Llibglib-2.0-0
    

    when i try to compile the example i got these

    130 error


  • Lifetime Qt Champion

    To link to a library you have to pass the parameter with a lowercase L. Uppercase L is for giving additional path to look at.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.