Programm doesn't start



  • Hello
    I have a problem, I created a browser, but when I run this on my computer, it's ok, but when I launch in another computer, the programme doesn't start.

    http://www.mediafire.com/download/s34r1aiu3n17kso/Chronos.rar

    Thank's


  • Lifetime Qt Champion

    Hi,

    Did you properly follow the Qt Deployment guidelines matching your platform ?




  • Qt Champions 2016

    Hi
    when run from his deployment folder

    dependency walker says

    Error: At least one required implicit or forwarded dependency was not found.
    Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
    Error: Modules with different CPU types were found.
    Warning: At least one delay-load dependency module was not found.
    Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.
    

    log file in folder says

    [0920/182327:ERROR:icu_util.cc(162)] Invalid file descriptor to ICU data received.
    [0920/182327:FATAL:icu_util.cc(265)] Check failed: result. 
    Backtrace:
    	GetHandleVerifier [0x00007FF94B6378C1+9665]
    	QtWebEngineCore::BrowserContextAdapter::isOffTheRecord [0x00007FF94B6012BC+265068]
    	QtWebEngineCore::CookieMonsterDelegateQt::hasCookieMonster [0x00007FF94BEF0648+4607832]
    	QtWebEngineCore::JavaScriptDialogController::qt_static_metacall [0x00007FF94AC10B36+2686598]
    	QtWebEngineCore::WebContentsAdapter::webChannel [0x00007FF94A977071+13777]
    	QtWebEngineCore::WebContentsAdapter::webChannel [0x00007FF94A97737F+14559]
    	QtWebEngineCore::WebContentsAdapter::WebContentsAdapter [0x00007FF94A96DDF7+119]
    	QtWebEngineCore::WebContentsAdapter::WebContentsAdapter [0x00007FF94A96DDAD+45]
    	QWebEnginePage::QWebEnginePage [0x00007FF96EB3378E+158]
    	QWebEnginePage::QWebEnginePage [0x00007FF96EB336CD+45]
    	QWebEngineView::page [0x00007FF96EB3F88D+45]
    	(No symbol) [0x00007FF66AE16A11]
    	(No symbol) [0x00007FF66AE13A59]
    	(No symbol) [0x00007FF66AE1922C]
    	(No symbol) [0x00007FF66AE262E4]
    	(No symbol) [0x00007FF66AE25473]
    	BaseThreadInitThunk [0x00007FF978268102+34]
    	RtlUserThreadStart [0x00007FF979A5C5B4+52]
    

    so big question is
    @Yacinoben
    Where did you copy the DLLS from?


  • Lifetime Qt Champion

    @mrjj I'm suspecting that parts of them come from Qt Creator


  • Qt Champions 2016

    @SGaist
    the log is is generated by the exe,
    deleted and tried to run .exe and it was created. but seems
    not very informative.



  • I copy the DLLS in msvc2015_64 folder



  • @Yacinoben said in Programm doesn't start:

    I copy the DLLS in msvc2015_64 folder

    This means you are on window. Can you try using the deployment tool and see if it works?



  • @VRonin it's work !!!
    thank you all for your answer


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.