"Project ERROR: Xcode not set up properly."


  • Qt Champions 2016

    today run into this problem

    did it all

    changed
    ```

    isEmpty($$list($$system("/usr/bin/xcrun -find xcodebuild 2>/dev/null"))): \
        error("Xcode not set up properly. You may need to confirm the license agreement by running /usr/bin/xcodebuild.")
    

    }

    also from http://stackoverflow.com/questions/33728905/qt-creator-project-error-xcode-not-set-up-properly-you-may-need-to-confirm-t

    did

    sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer
    

    confirmed license agreement

    xcodebuild -license
    

    still getting errors while building for iOS
    XCode 8, OS 10.11.6

    Project ERROR: Xcode not set up properly. You may need to confirm the license agreement by running /usr/bin/xcodebuild.
    15:47:05: The process "/daten/_qt_sdks/sdk_570/5.7/ios/bin/qmake" exited with code 3.
    Error while building/deploying project ...

    :(



  • @ekkescorner Hi, I'm uploaded video where you can see how I fix this problem. On video you can see OS X 10.12 but this also works on OS X 10.11. Please watch video and if you have any questions let me know.


  • Qt Champions 2016

    @shav thx - but I already did all these steps
    verified twice ;-)

    now downloaded Xcode 7.3.1 besides Xcode 8
    select switch Xcode to 7.3.1

    and I can work on



  • @ekkescorner
    Move to the Qt install library and got to the Qt_install_folder/5.7/ios/mkspecs/features/mac/default_pre.prf (!!!iOS not clang) and find the line
    isEmpty($$list($$system("/usr/bin/xcrun -find xcrun 2>/dev/null")))):
    and replace:
    isEmpty($$list($$system("/usr/bin/xcrun -find xcodebuild 2>/dev/null"))):
    save the changes and reload the QtCreator and enjoy :)


  • Qt Champions 2016

    @murdock thanks. this was the trick: I did it in clang - not ios

    Now the Xcodeproject was built with Xcode 8 :)

    But now another error:

    Signing for "xxx" requires a development team. Select a development team in the project editor.
    Code signing is required for product type 'Application' in SDK 'iOS 10.0'
    
    make: *** [xcodebuild-debug-iphoneos] Error 65
    12:55:52: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project xxx (kit: iphoneos-clang Qt 5.7.0 (ios))
    

    I can open Xcode 8, select the Team and run the App on Device
    Do I have to set somethin in Xcode 8 ?

    thx helping



  • @ekkescorner Do you have Apple Developer Program for you Apple ID? It's looks like you don't have it or you mac is not configuring for your developer program.

    You can check it in Xcode.

    1. Open Xcode
    2. Open Xcode preference (Top Menu -> Xcode -> Preference) or CMD + , (comma).
    3. In Preference window find "Account" tab
    4. Check if you have any Apple ID accounts on the left list. If you don't have it in list you can add it.
      4.1. On the bottom you will find the "+" button. Click to it and select Apple ID.
      4.2. Enter your apple Id and password and click save.
      4.3. Now you will see your new apple id in the list.
    5. Select you new apple id from list.
    6. On the center of the window you will see list of developers program for your apple id.
    7. Select one from them and click "view" button.
    8. Check the certificates they must be installed.
      8.1. If you don't installed certificates click to the button near the name of certificates.
      8.2. After you install certificates you need to create developer provision profiles.
      8.3. Downloads all need provision profiles.
    9. If you have all certificates please check provision profiles for your project.
      9.1. Find Info.plist of your project. It's must be in build folder for your project.
      9.2. Open info.plist and copy bundle id for your project
      9.3. Open Apple Developer Manager website and select section "Certificates, Provisions"
      9.4. Select applications list and search application with you bundle id.
      9.5. If you don't have this application with bundle id please create it.
      9.6. Open section Provisions and create provision profile for you new application.
      9.7. Download and install your new provision profile.
    10. Try rebuild your project. Now you must build it correct.

    Also you can use Xcode for build your project. In Xcode you must select team:

    1. Open your project in Xcode
    2. Select project file in the left list.
    3. Open general section.
    4. Select your team form the list for Debug build and Release build.
    5. Build you project.

    Hope the will help for you.


  • Qt Champions 2016

    I have no problem to sign and build my project from Xcode 8
    problem is building the project from QtCreator:

    this works well for Xcode 7.3 but from Xcode 8.0 something changed with signature and so the build process from QtCreator creates thge Xcode project and then fails with

    Signing for "xxx" requires a development team. Select a development team in the project editor.
    Code signing is required for product type 'Application' in SDK 'iOS 10.0'
    
    make: *** [xcodebuild-debug-iphoneos] Error 65
    12:55:52: The process "/usr/bin/make" exited with code 2.
    

    Opening the xcodeproject there's no development team selected. I can select and build / run on iPhone from inside Xcode 8.

    The run-on-device is broken now. switching back to Xcode 7.3 it works well

    Doing a google search for

    requires a development team. Select a development team in the project editor.
    Code signing is required for product type 'Application' in SDK 'iOS 10.0'
    

    you'll see that many other projects doiung builds with Xcode are broken with Xcode 8

    looking forward to a solution.



  • @ekkescorner
    I'm having exactly the same code signing problem. With Xcode 7.3 I can compile my project using QtCreator but with Xcode 8 it doesn't work. I can only compile using Xcode which makes the whole process a lot more complicated since I need both QtCreator (to write my code) and Xcode running at the same time.

    This might seem like a small rpoblem but it is very time consuming. Please, we need a fix for this quickly !


  • Lifetime Qt Champion

    @Kostas Hi, the forum is not the right place to ask for fixes. You should rather take a look at the bug report system to see if it's something known. If not, please consider opening a new report.




  • Lifetime Qt Champion

    Thanks !



  • @shav thank you so much,Perfekt Video!! Finally its work.



  • Hi All,

    XCode 8.1 got published yesterday. Does anyone has new information on compatibility with Qt?



  • @_ovz

    hi!

    I just installed the version 8.1 but i've same problem.

    alt text

    Any help?


  • Lifetime Qt Champion

    You should likely follow the same recommandation as for Xcode 8.


  • Qt Champions 2016

    @_ovz haven't updated from 8.0 to 8.1 yet. after all the trouble to make Xcode 8 run I'm also waiting to get feedback from others if this update is harmless ;-)



  • No changes from Xcode 8.0 to 8.1. Same recommendations as for 8.0


  • Qt Champions 2016

    @Kostas yep 8.1 works well for me, too. had to upgrade to 8.1 because updated iPhone to 10.1



  • hi guys! how to fix "Unsupported device specifier option."? I'm trying to build Qt 5.7 with Xcode 8.1 and got error:

    xcodebuild build -scheme xmlpatterns  -sdk iphonesimulator   -destination "id=12.9 inch" -destination-timeout 1
    Build settings from command line:
        SDKROOT = iphonesimulator10.1
    
    Build settings from command line:
        SDKROOT = iphonesimulator10.1
    
    2016-11-08 16:27:45.875 xcodebuild[35931:188276] +dataWithFirstBytes:1024 ofFile:"/Users/dead_man/Qt/5.7/myios/qtxmlpatterns/.qmake.cache" failed, errno = 2
    2016-11-08 16:27:45.875 xcodebuild[35932:188277] +dataWithFirstBytes:1024 ofFile:"/Users/dead_man/Qt/5.7/myios/qtxmlpatterns/.qmake.cache" failed, errno = 2
    xcodebuild: error: Unable to find a destination matching the provided destination specifier:
    		{ id:12.9 inch }
    
    	Unsupported device specifier option.
    	The device “My Mac” does not support the following options: id
    	Please supply only supported device specifier options.
    
    	Available destinations for the "xmlpatternsvalidator" scheme:
    		{ platform:iOS, id:62c9771b7caf1b4c1c0190d1eb24eb0796fa49a5, name:iPhone (Иван) }
    		{ platform:iOS Simulator, id:F6B7CF61-5397-406E-A286-D45470262967, OS:8.1, name:iPad 2 }
    		{ platform:iOS Simulator, id:DED75CE3-8C71-455C-83FA-41B10C26636E, OS:8.1, name:iPad Air }
    		{ platform:iOS Simulator, id:EA1CB5D5-B606-49F6-BC61-CA01DB0CB4AD, OS:10.1, name:iPad Air }
    		{ platform:iOS Simulator, id:3B10D6D2-EAF2-4BE8-86CA-01081A75C758, OS:10.1, name:iPad Air 2 }
    		{ platform:iOS Simulator, id:F928B151-BC12-4345-91F5-F558060D2448, OS:10.1, name:iPad Pro (9.7 inch) }
    		{ platform:iOS Simulator, id:FFC4A4D6-3A01-4CAF-B80C-D74E6C9B1D46, OS:10.1, name:iPad Pro (12.9 inch) }
    		{ platform:iOS Simulator, id:A376E5F9-678A-4693-99B8-B794B68D52DF, OS:8.1, name:iPad Retina }
    		{ platform:iOS Simulator, id:06030CC4-8C3F-4FBF-BE3B-0EC5226D0B6F, OS:10.1, name:iPad Retina }
    		{ platform:iOS Simulator, id:9F669251-8784-44DC-A73A-853CA42D177E, OS:8.1, name:iPhone 4s }
    		{ platform:iOS Simulator, id:F6163C95-5B4F-4F00-A94E-A3AA9410DBE8, OS:8.1, name:iPhone 5 }
    		{ platform:iOS Simulator, id:31CD8F53-B7D0-471A-B30D-740F3D470873, OS:10.1, name:iPhone 5 }
    		{ platform:iOS Simulator, id:F3AE95A3-A1B5-47C3-BECE-7BCE642C98CA, OS:8.1, name:iPhone 5s }
    		{ platform:iOS Simulator, id:6175F32A-37E3-419D-AD44-5B7EFFDC9EE3, OS:10.1, name:iPhone 5s }
    		{ platform:iOS Simulator, id:44DCB1F7-74B5-40E0-8EFD-09BA8DB4225F, OS:8.1, name:iPhone 6 }
    		{ platform:iOS Simulator, id:CD3F00F2-4155-4120-AECD-D29ECDE9C5D7, OS:10.1, name:iPhone 6 }
    		{ platform:iOS Simulator, id:23FDCD68-529A-4988-AF52-CF0B20799429, OS:8.1, name:iPhone 6 Plus }
    		{ platform:iOS Simulator, id:A6137D32-30DE-4C8E-BD10-986EB3404212, OS:10.1, name:iPhone 6 Plus }
    		{ platform:iOS Simulator, id:6545FC44-81DD-4D25-A12D-15610B0B3861, OS:10.1, name:iPhone 6s }
    		{ platform:iOS Simulator, id:1BE272F0-D2DC-43C0-ACA8-767F7635B11A, OS:10.1, name:iPhone 6s Plus }
    		{ platform:iOS Simulator, id:821127DE-191A-4DDC-93D8-CBCD4B5D791D, OS:10.1, name:iPhone 7 }
    		{ platform:iOS Simulator, id:8D8985F9-4934-428B-BAC7-2FC99B845139, OS:10.1, name:iPhone 7 Plus }
    		{ platform:iOS Simulator, id:F60DF7B3-0BB8-4BF1-9A9A-A5DC6EB70A3E, OS:10.1, name:iPhone SE }
    
    	Ineligible destinations for the "xmlpatternsvalidator" scheme:
    		{ platform:iOS, id:dvtdevice-DVTiPhonePlaceholder-iphoneos:placeholder, name:Generic iOS Device }
    		{ platform:iOS Simulator, id:dvtdevice-DVTiOSDeviceSimulatorPlaceholder-iphonesimulator:placeholder, name:Generic iOS Simulator Device }
    xcodebuild: error: Unable to find a destination matching the provided destination specifier:
    		{ id:12.9 inch }
    
    	Unsupported device specifier option.
    	The device “My Mac” does not support the following options: id
    	Please supply only supported device specifier options.
    
    	Available destinations for the "xmlpatterns" scheme:
    		{ platform:iOS, id:62c9771b7caf1b4c1c0190d1eb24eb0796fa49a5, name:iPhone (Иван) }
    		{ platform:iOS Simulator, id:F6B7CF61-5397-406E-A286-D45470262967, OS:8.1, name:iPad 2 }
    		{ platform:iOS Simulator, id:DED75CE3-8C71-455C-83FA-41B10C26636E, OS:8.1, name:iPad Air }
    		{ platform:iOS Simulator, id:EA1CB5D5-B606-49F6-BC61-CA01DB0CB4AD, OS:10.1, name:iPad Air }
    		{ platform:iOS Simulator, id:3B10D6D2-EAF2-4BE8-86CA-01081A75C758, OS:10.1, name:iPad Air 2 }
    		{ platform:iOS Simulator, id:F928B151-BC12-4345-91F5-F558060D2448, OS:10.1, name:iPad Pro (9.7 inch) }
    		{ platform:iOS Simulator, id:FFC4A4D6-3A01-4CAF-B80C-D74E6C9B1D46, OS:10.1, name:iPad Pro (12.9 inch) }
    		{ platform:iOS Simulator, id:A376E5F9-678A-4693-99B8-B794B68D52DF, OS:8.1, name:iPad Retina }
    		{ platform:iOS Simulator, id:06030CC4-8C3F-4FBF-BE3B-0EC5226D0B6F, OS:10.1, name:iPad Retina }
    		{ platform:iOS Simulator, id:9F669251-8784-44DC-A73A-853CA42D177E, OS:8.1, name:iPhone 4s }
    		{ platform:iOS Simulator, id:F6163C95-5B4F-4F00-A94E-A3AA9410DBE8, OS:8.1, name:iPhone 5 }
    		{ platform:iOS Simulator, id:31CD8F53-B7D0-471A-B30D-740F3D470873, OS:10.1, name:iPhone 5 }
    		{ platform:iOS Simulator, id:F3AE95A3-A1B5-47C3-BECE-7BCE642C98CA, OS:8.1, name:iPhone 5s }
    		{ platform:iOS Simulator, id:6175F32A-37E3-419D-AD44-5B7EFFDC9EE3, OS:10.1, name:iPhone 5s }
    		{ platform:iOS Simulator, id:44DCB1F7-74B5-40E0-8EFD-09BA8DB4225F, OS:8.1, name:iPhone 6 }
    		{ platform:iOS Simulator, id:CD3F00F2-4155-4120-AECD-D29ECDE9C5D7, OS:10.1, name:iPhone 6 }
    		{ platform:iOS Simulator, id:23FDCD68-529A-4988-AF52-CF0B20799429, OS:8.1, name:iPhone 6 Plus }
    		{ platform:iOS Simulator, id:A6137D32-30DE-4C8E-BD10-986EB3404212, OS:10.1, name:iPhone 6 Plus }
    		{ platform:iOS Simulator, id:6545FC44-81DD-4D25-A12D-15610B0B3861, OS:10.1, name:iPhone 6s }
    		{ platform:iOS Simulator, id:1BE272F0-D2DC-43C0-ACA8-767F7635B11A, OS:10.1, name:iPhone 6s Plus }
    		{ platform:iOS Simulator, id:821127DE-191A-4DDC-93D8-CBCD4B5D791D, OS:10.1, name:iPhone 7 }
    		{ platform:iOS Simulator, id:8D8985F9-4934-428B-BAC7-2FC99B845139, OS:10.1, name:iPhone 7 Plus }
    		{ platform:iOS Simulator, id:F60DF7B3-0BB8-4BF1-9A9A-A5DC6EB70A3E, OS:10.1, name:iPhone SE }
    
    	Ineligible destinations for the "xmlpatterns" scheme:
    		{ platform:iOS, id:dvtdevice-DVTiPhonePlaceholder-iphoneos:placeholder, name:Generic iOS Device }
    		{ platform:iOS Simulator, id:dvtdevice-DVTiOSDeviceSimulatorPlaceholder-iphonesimulator:placeholder, name:Generic iOS Simulator Device }
    make[3]: *** [xcodebuild-iphonesimulator] Error 70
    make[3]: *** [xcodebuild-iphonesimulator] Error 70
    make[2]: *** [sub-xmlpatterns-make_first] Error 2
    make[2]: *** Waiting for unfinished jobs....
    make[2]: *** [sub-xmlpatternsvalidator-make_first] Error 2
    make[1]: *** [sub-tools-make_first] Error 2
    make: *** [module-qtxmlpatterns-make_first] Error 2
    

  • Lifetime Qt Champion

    From git or from the archive ?



  • @SGaist i installed source from Maintenance Tool. I'll try from git now...



  • I build Qt 5.8 from git, but project not compiling now. Error: Unknown module(s) in QT: qml quick svg multimedia bluetooth
    But i has make all this modules


  • Lifetime Qt Champion

    Did you call make install ?



  • Hello all, I'm using Qt5.5.1 and xcode8.2.1 and mac os 10.12.2

    1. First i faced "Project ERROR: Xcode not set up properly." error i solved it using above solution given at the top.
    2. Then i'm facing "Project ERROR: Current iphonesimulator SDK version (10.2) is too old. Please upgrade Xcode." error i go through the video uploaded by mr.shav but i can't able to run to app, showing same error.
    3. using cmd xcodebuild -showsdks shows sdk version as -sdk iphoneos10.2.
    4. Even i set the "sdk.prf" the line as "lessThan(QMAKE_MAC_SDK_VERSION, “10.2”): "
      can't able to run my app..
      Is there any other way to solve this problem

    Thank you.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Please update to 5.8 if possible, it should contain the fixes you need and has just been released.


Log in to reply