How come QtCreator does not show me methods of QElapsedTimer?



  • Hello,

    After pressing a dot after the QElapsedTimer instance I would expect to see the available methods of this instance but I don't, why?

    Here is the example:

    alt text

    Maybe it is because the designtime parser has problem with qelapsedtimer.h file?

    alt text

    But I haven't changed anything it that file. My program compiles fine.

    My version is Qt Creator 3.5.1 Built on Oct 15 2015 01:55:47

    Best regards.


  • Moderators

    This usually happens when you're missing an include for a class. It might compile because it gets included via some other includes, but the syntax suggestions aren't that smart. It's usually better to have that include anyway so make sure you have #include <QElapsedTimer> in that file.

    Btw. Don't link to images on your computer. The rest of the internet doesn't have access to it ;)



  • @Chris-Kawa Thanks for the answer, unfortunately including the header does not help. I've tested it before posting the question but forgot to mention it.

    Regarding the images, do you mean that you do not see them and only I can see them?


  • Moderators

    Well it works fine for me on Qt Creator 4.1.0. Is there a reason you're using such old version? If not I would try to update first and see if that helps.

    As for the images - yes, unfortunately. Try to upload them into some hosting site like photobucket and link from there.



  • @Chris-Kawa Thanks for checking it out. I've updated the pictures, I hope you can see them now. I don't understand the feature which lets me upload the images which only I can see tho :)
    Getting back to my problem, I think it is becasue the editor which has problems of parsing the header (red underlines).

    Why am I using such old version? Simply, because it did all what I wanted:) I've installed it 8 months ago and since then I am developing my application and I am happy with it:) I was thinking about the update but I am afraid of loosing all my settings. Today I've tried to run qt-unified-windows-x86-2.0.3-1-online.exe and it wants me to unpack the new version somewhere, so I think it is not aware about the old version?

    What would be the best way to update, should I unpack it to the same place in which my current version resides? I would like to keep my settings (compiler paths and so on..).

    Thank you for your time :)


  • Moderators

    @Wodzu The best way to update is to use the Maintenance Tool



  • @jsulm Thank you, I whish I could have properly configured notifications, to see your answer earlier. ;)

    I've just come here to tell others how to do it and here is your answer :)

    I can also confirm that in new versionof Qt creator the parsing problem has been solved.

    Regards.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.