Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Installer Error



  • I am running window 7 with minGW build kit. I have gone through the installer tutorial and keep getting the error of "binarycreator is not recognized as an internal or external command, operable program or batch file". I have checked and it is in the system "path" as "C:\Qt\QtIFW2.0.3\bin". Any ideas?



  • @xopherira It is probably not in PATH. You should explicitly call binary creator using full path, or add that directory to PATH env variable.



  • I believe that is what I did. Steps I took, Control Panel-Advanced sytem settings-Environment variables-added C:\Qt\QtIFW2.0.3\bin to PATH. I still get the error.


  • Lifetime Qt Champion

    Hi,

    Double check that the environment of your project in Qt Creator was also update. See the Project panel for that.



  • Thanks, where do i need to specifically? The rest of the build and setup process seems to work fine.


  • Lifetime Qt Champion

    Well, in the Project panel. Check both the Build and Run part for the environment variables.



  • @SGaist Sorry for the not getting back to this earlier, finished up another project. I added under project and get same error, is there some nuance that i might be missing?



  • This is what PATH looks like under QT project. C:\Qt\Qt5.6.0\5.6\mingw49_32\bin;C:\Qt\Qt5.6.0\Tools\mingw492_32\bin;C:\ProgramData\Oracle\Java\javapath;%CommonProgramFiles%\Microsoft Shared\Windows Live;C:\Program Files (x86)\Intel\iCLS Client;C:\Program Files\Intel\iCLS Client;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files\Intel\WiFi\bin;C:\Program Files\Common Files\Intel\WirelessCommon;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Common Files\Lenovo;C:\ProgramData\Lenovo\ReadyApps;C:\Program Files (x86)\IBM\Client Access\Emulator;C:\Program Files (x86)\IBM\Client Access\Shared;C:\Program Files (x86)\IBM\Client Access;C:\Program Files (x86)\Shoreline Communications\ShoreWare Client;C:\Program Files (x86)\Shoreline Communications\ShoreWare Client\win64;C:\Program Files\Microsoft SQL Server\120\Tools\Binn;C:\Program Files\Microsoft SQL Server\130\Tools\Binn;C:\Program Files (x86)\MySQL\MySQL Fabric 1.5 & MySQL Utilities 1.5;C:\Program Files (x86)\MySQL\MySQL Fabric 1.5 & MySQL Utilities 1.5\Doctrine extensions for PHP;C:\Anaconda3;C:\Anaconda3\Scripts;C:\Anaconda3\Library\bin;C:\Program Files\Git\cmd;C:\Program Files (x86)\ShoreTel\Contact Center\Agent\Bin;C:\Qt\QtIFW2.0.3\bin;C:\MinGW\bin;C:\MinGW\msys\1.0\bin;C:\Qt\Qt5.6.0\5.6\mingw49_32\bin;C:\Qt\QtIFW2.0.3\bin;


  • Lifetime Qt Champion

    On the Run part ?



  • Its under both run and build, is this incorrect?


  • Lifetime Qt Champion

    Where's that tutorial you are following exactly ?



  • Here is the link to youtube web tutorial for setting up installer.
    https://www.youtube.com/watch?v=pXRwgEP_q-Y





  • @xopherira I believe you have already solved this problem. But this reply is for someone else who has same problem.

    The answer is;
    You have to set the system path not user path. After your change have to close the existing command window and open a new one.


Log in to reply