gui compilation doesn't find opengl includes



  • Hi

    I'm cross compiling qt5.7 from the sources and stuck on an include issue.
    when the gui module compiles, it fails to find GLES3/gl3.h file, even though the file exists in several dirs.
    The command that fails is:

    /home/shlomi/buildroot-2016.05/output/host/usr/bin/arm-buildroot-linux-uclibcgnueabihf-g++ -c -pipe -march=armv7-a -marm -mthumb-interwork -mfpu=neon-vfpv4 -mtune=cortex-a7 -mabi=aapcs-linux -mfloat-abi=hard -O3 -std=c++1y -fvisibility=hidden -fvisibility-inlines-hidden -D_REENTRANT -fno-exceptions -Wall -W -Wvla -fPIC -DQT_NO_MTDEV -DQT_NO_LIBUDEV -DQT_NO_TSLIB -DQT_NO_LIBINPUT -DQT_NO_USING_NAMESPACE -DPNG_ARM_NEON_OPT=0 -DQT_ENABLE_HARFBUZZ_NG -DENABLE_PIXMAN_DRAWHELPERS -DQT_BUILD_GUI_LIB -DQT_BUILDING_QT -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_DEPRECATED_WARNINGS -DQT_DISABLE_DEPRECATED_BEFORE=0x050000 -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_CORE_LIB -DQT_NO_EXCEPTIONS -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I. -I../3rdparty/libpng -I../3rdparty/zlib -I../3rdparty/harfbuzz-ng/include -I../3rdparty/zlib -I../../include -I../../include/QtGui -I../../include/QtGui/5.7.0 -I../../include/QtGui/5.7.0/QtGui -I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux -I../../include/QtCore/5.7.0 -I../../include/QtCore/5.7.0/QtCore -I../../include/QtCore -I.moc -I../../mkspecs/devices/linux-rasp-pi2-g++ -o .obj/qwindowsysteminterface.o kernel/qwindowsysteminterface.cpp
    

    if I add to the include manually

    -I../3rdparty/angle/include/
    

    then compilation of this specific file succeeds.
    what is the best way to fix it?

    This was my configure cmd:

    ./configure \
    -release \
    -opengl es2 \
    -optimized-qmake \
    -no-pch \
    -make libs \
    -make tools \
    -reduce-exports \
    -device linux-rasp-pi2-g++ \
    -device-option CROSS_COMPILE=/home/shlomi/buildroot-2016.05/output/host/usr/bin/arm-buildroot-linux-uclibcgnueabihf- \
    -prefix /home/shlomi/buildroot-2016.05/output/target/usr/local/qt5.7 \
    -opensource -nomake examples -nomake tests \
    -confirm-license
    


  • solved it by doing:

    sudo apt-get install mesa-common-dev
    

    and by removing and copying over src/gui dir


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.