Android SDK error when "executing step "Build Android APK""



  • I'm having my first shot at Android development using Qt and have run into a wall or two while setting up my environment.
    I have downloaded the required packages as described here http://doc.qt.io/qt-5/androidgs.html and have updated the SDK.
    When attempting to build and run an application on either a virtual or physical device I get the following error:

    BUILD FAILED
    /home/daniel_j/compiled/androidsdk/android-sdk-linux/tools/ant/build.xml:888: The following error occurred while executing this line:
    /home/daniel_j/compiled/androidsdk/android-sdk-linux/tools/ant/build.xml:890: The following error occurred while executing this line:
    /home/daniel_j/compiled/androidsdk/android-sdk-linux/tools/ant/build.xml:902: The following error occurred while executing this line:
    /home/daniel_j/compiled/androidsdk/android-sdk-linux/tools/ant/build.xml:283: null returned: 1
    
    Total time: 1 second
    Building the android package failed!
      -- For more information, run this command with --verbose.
    10:29:47: The process "/home/daniel_j/compiled/qtdev/5.7/android_x86/bin/androiddeployqt" exited with code 14.
    Error while building/deploying project untitled (kit: Android for x86 (GCC 4.9, Qt 5.7.0))
    When executing step "Build Android APK"
    

    I cannot see a particular issue listed in the error.

    Whether related or not I also have this issue with the NDK:

    The GDB in the NDK appears to have broken python support.
    

    It attempts to link me to a fixed version, however I am unable to download it (internal server error). http://download.qt.io/official_releases/gdb/
    Is this particular issue related to the one above?
    Thanks for your time.



  • I would check two things:

    1. NDK version. If you downloaded the latest (v 12 something), you could try downgrading it to 11, as I think the latest has had some issues. (I found that after changing the NDK, QtCreator is usually confused so you may want to reinstall the Qt for Android SDK)
    2. Your kit. If you are making software for a regular Android device, use a kit that has ARMv7 in its name


  • Thanks for the suggestions!
    Sadly I still get the same results with older NDK versions.
    I have been trying two kits, one for my device and the other a virtual device, neither work - both give the same error.



  • It seems installing JDK 8 solved thei ssue at hand, oen step closer!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.