[Solved] Stepping into Qt library code whilst debugging



  • Hi,

    I'm using the latest Qt version (5.7) and I'm using Visual Studio 2015 to compile into 64-bit code.
    The debugger has been set up as per tips in : http://doc.qt.io/qtcreator/creator-debugger-engines.html
    Debugging works fine but I CANNOT step into the Qt libraries themselves, despite the *.pdb files being present in the lib folder and the source files under Qt\5.7\src. So, what do I do wrong here ??

    Thanks, Bart



  • Most common issue I know is that, for some reason, you debugger finds and uses a release version of your Qt dlls first.



  • I found the solution, when I realized that the debugger took 3 x F11 (step into) before moving to the next line. What was missing was a reference to the Qt source files. Solution :

    1. Select Projects tool in QtCreator
    2. Select Manage Kits...
    3. Select Debugger in Popup Dialog
    4. Look for "Add Qt sources..." button
    5. Provide the path for the Qt source folder
    6. This path will be added as "Target Path"
    7. That's all - it works now...

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.