Creating dll for use in VS (C#) - MSVC version of Qt required?



  • Hi,

    Qt version: 5.7. Build environment: gcc / mingw 5.30

    I have some code which I want to put into a DLL. However, this dll is supposed to be used in a program developed in C# with Visual Studio 2015. I am not sure whether I can still use the MinGW Qt version which I have installed, or whether the MSVC variant is required for that. Can you help?

    Thanks!


  • Lifetime Qt Champion

    Hi,

    You can't mix and match compilers on Windows. Even different versions of Visual Studio are nor compatible one with the other.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.